Polar Inversion didn't work

Bug #1190207 reported by Pavel on 2013-06-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Medium
Unassigned

Bug Description

Mac 10.7.5

First i installed Pinta and after awhile Mono. All effects work fine except this, but this effect one what i need, and i can't find any other program on mac with this effect.

http://img832.imageshack.us/img832/1871/screenshot20130612at417.png

Pavel (one2gov) on 2013-06-12
description: updated
description: updated
grofaty (grofaty) wrote :

As I see on your image it is working fine. Maybe you have lowered Quality too much. For start leave the Quality at 5.

If you still think this is a bug, can you please install the latest Pinta development from:
https://groups.google.com/forum/?hl=en&fromgroups=#!topic/pinta/jIDZUvbum-g
and retest.

Can you please also describe what is the result you are expecting? Can you provide some details with other image program like Gimp for example? Please write step-by-step instructions.

Pavel (one2gov) wrote :

I am expecting to see http://img560.imageshack.us/img560/6167/screenshot20130612at620.png

Here is a little screencast. http://www.youtube.com/watch?v=ArDTIcIuw3c&feature=youtu.be

p.s Pinta 1.5 works exactly the same.

grofaty (grofaty) wrote :

I tested this problem and I have notice two things:
a) From screencast I see that on Mac (I don't have a Mac, so can't confirm this on my case) when using Polar Inversion and changing slides it doesn't happen anything, but using other effects are applied immediately. I tried this on Windows XP master and changes does take effect every time I change slider.

b) I have looked at the image from #2 and tested on Pinta master on Windows XP and compared with Paint.net 3.5 on Windows XP and for Edge Behavior "Wrap" and I see it does not produce the same result, don't know if this is a bug or intentional. I am not an expert on using effects, maybe someone else should look at this problem.

tags: added: osx
tags: added: effects
grofaty (grofaty) wrote :

Also tested on master on Ubuntu 12.04.

At #3:
a) Like on Windows. Changing sliders and there are effects visible on canvas.
b) The same as on Windows.

Cameron White (cameronwhite91) wrote :
Changed in pinta:
assignee: nobody → Cameron White (cameronwhite91)
importance: Undecided → Medium
milestone: none → 1.5
status: New → Fix Committed
grofaty (grofaty) wrote :

I tested master on Windows XP and I think now major bug was fixed: polar effect now works fine (point b from #3).

But it looks like Quality slider does not have any effect (also tested on "yesterday master" on another PC and this was also not working, so not today's regression). I compared Quality slider with Paint.NET and in Paint.NET it displays different "quality" image if using 1 or 5. I am marking this bug back to New.

Pavel (one2gov) wrote :

Can someone compile this version? https://github.com/PintaProject/Pinta/commit/ba92b6ef909fe99bd0ebaddf13bdc9c486ab7e09
i really wanna test it out!

I tried to compile it myself, but there to much programs to install with too much errors.

Cameron White (cameronwhite91) wrote :

I'll be putting together a new development preview very soon, so you can test it out then.

Pavel (one2gov) wrote :

Thank you this is really soon :)

I captured another screencast http://www.youtube.com/watch?v=LtsfXiJHuxI&feature=youtu.be

Here is you can see:

-Quality 1 and dragging cause this error in 100% times

System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.InvalidOperationException: LivePreviewManager.Start() called while live preview is already enabled.
  at Pinta.Core.LivePreviewManager.Start (Pinta.Core.BaseEffect effect) [0x00000] in <filename unknown>:0
  at Pinta.Core.EffectsManager+<RegisterEffect>c__AnonStoreyC.<>m__11 (System.Object sender, System.EventArgs e) [0x00000] in <filename unknown>:0
  at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0
  --- End of inner exception stack trace ---
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in <filename unknown>:0
  at System.Reflection.MethodBase.Invoke (System.Object obj, System.Object[] parameters) [0x00000] in <filename unknown>:0
  at System.Delegate.DynamicInvokeImpl (System.Object[] args) [0x00000] in <filename unknown>:0
  at System.MulticastDelegate.DynamicInvokeImpl (System.Object[] args) [0x00000] in <filename unknown>:0
  at System.Delegate.DynamicInvoke (System.Object[] args) [0x00000] in <filename unknown>:0
  at GLib.Signal.ClosureInvokedCB (System.Object o, GLib.ClosureInvokedArgs args) [0x00000] in <filename unknown>:0
  at GLib.SignalClosure.Invoke (GLib.ClosureInvokedArgs args) [0x00000] in <filename unknown>:0
  at GLib.SignalClosure.MarshalCallback (IntPtr raw_closure, IntPtr return_val, UInt32 n_param_vals, IntPtr param_values, IntPtr invocation_hint, IntPtr marshal_data) [0x00000] in <filename unknown>:0

-Paint.net respond faster and has that little arrow pointing away from the center, but it has little "Amount 0.00" bug .

Pavel (one2gov) wrote :

"Quality 1" bug absent on 10.8

grofaty (grofaty) wrote :

@Pavel, I have looked at #10 video, but I can't see a crash on video. You also written that: "Quality 1 and dragging cause this error in 100% times", but I see on video that you have moved Quantity slider to 1 and Pinta did not crash. Can you please write step-by-step instructions how to crash a Pinta using Quantity slider?

I was testing Polar Inversion effect on master on Windows XP, moving slider in all sort of a ways, but could not crash the Pinta. Maybe Mac OS specific.

Pavel (one2gov) wrote :

- Set quality to 1
- change center offset
- try to do anything and this error will appear
Only in mac Os x 10.7

It's not crash but it's close.

grofaty (grofaty) wrote :

I can't reproduce this on Windows XP. Maybe you have two Gtk# installed and Pinta uses old one. Can you check if two Gtk# are installed and if it does uninstall the oldest one and retest with latest development. By the way did you uninstall Pinta before installing latest development it may also be so old version of Pinta running.

Can someone else reproduce this problem on Os X 10.7?

Changed in pinta:
status: Fix Committed → New
Pavel (one2gov) wrote :

If i used old version polar inversion would not be worked at all.
Yes i uninstalled previous versions.

grofaty (grofaty) wrote :

I have retested the #6 using master and I think "Quality" slider works fine (now I have also tested on previous revisions), I just didn't spot this 'quality' working before, but now I can, so #6 was false report, sorry for inconvenience. Reproduce working-fine:
1. Open smaller image e.g. 300 x 300 or crop existing image (very important to spot the problem - if image is zoomed then this effect is not possible to see, unless zoom-out).
2. Effects | Polar Inversion.
3. Amount = -1 and Edge Behavior = Wrap.
4. Now Quality = 1 and change slider to Quality = 5 and it is clear Quality slider is working fine.
Both tests done on master on Windows XP and master on Ubuntu 12.04. Don't have OSX to test the same on it.

grofaty (grofaty) wrote :

So as I understand the only problem is currently reported crash in #10 which could be produced currently only by Pavel with #13 on OSx. It would be nice if someone else using OSX could try the #10 procedure and report if crash appears or not, so that we know if this is bug or some single user problem (some mess in installation or something). It would be nice if this could be tested, because this is the last bug remaining in Pinta 1.5 development cycle.

@Pavel, do you by any chance have more then one OSX computers? If yes, please test and report an don't forget to write the version of OSX you are testing on.

Changed in pinta:
milestone: 1.5 → 1.6
grofaty (grofaty) wrote :

I am removing "Cameron White" from "Assigned to", because there is more then year and probably not working with this bug currently. Just to have updated statuses for bugs.

Can someone using OSx confirm if this is bug or no? I am setting this bug report to Incomplete until someone else confirms the problem.

Changed in pinta:
status: New → Incomplete
assignee: Cameron White (cameronwhite91) → nobody
Cameron White (cameronwhite91) wrote :

This shouldn't be targeted to the 1.6 milestone if it cannot be confirmed.

Changed in pinta:
milestone: 1.6 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers