Rectangle Select cursor is the same as the Pan cursor

Bug #1188143 reported by grofaty on 2013-06-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Low
Cameron White

Bug Description

Pinta compiled from master on Windows XP:
1. New image 16 x 16.
2. Zoom to 2400%.
3. Rectangle Select and select some area on canvas. Observe Rectangle mouse icon. Icon is OK.
4. Now just move move to gray area beside canvas (don't click anything) and move back mouse to canvas.
Now problem appears: Rectangle Select icon automatically changes to Pan icon, expected is mouse icons should not get changed if I didn't select Pan from Tools.

This problem only appears on small images. This problem does not appear on normal size images e.g. 500 x 500.

Also tested on (and the same problem):
- Pinta-1.5-preview-20130518 on Windows XP,
- Pinta compiled from master on Ubuntu 12.04

grofaty (grofaty) wrote :

Playing little bit around and I think this has nothing to do with Pan, but it looks like this is a resize action from rectangle selection. We are using the same icon for resize rectangle selection and Pan. We should have different icons for each of the actions.

It looks like "resize" selection on small images is not sensitive at all - large area to select from. This mouse sensitivity should be reduced.

grofaty (grofaty) wrote :

Another problem found out:
1-4 steps from bug report.
5. Click on Deselect All icon from toolbar.
6. Move mouse back to canvas and "Pan" icon is still displayed despite no resize selection is possible.

grofaty (grofaty) wrote :

I have created three new icons that should be used when resize appears. Icon should change according of the object that was used for selection:
- if RectangleSelect was used select an area then RectangleSelectResize should be used when resize appears,
- if EllipseSelect was used to select an area then EllipseSelectResize should be used when resize appears,
- if LassoSelect was used to select an area then LassoSelectResize should be used when resize appears.

grofaty (grofaty) wrote :
grofaty (grofaty) wrote :
grofaty (grofaty) wrote :
grofaty (grofaty) wrote :

Above three icons are related to bug 1181802 to make mouse icons more beautiful and more meaningful. Hope they get accepted into Pinta.

grofaty (grofaty) wrote :

Forgot to write... Above three icons are pixel compatible with icons from bug 1181802. So Cursor.EllipseSelectResize.png should have exactly the same mouse acceptance focus as Cursor.EllipseSelect.png etc.

Cameron White (cameronwhite91) wrote :

I'm not a big fan of those cursors, since they suggest that the selection can only be resized in a single direction. I'd rather use the standard Gdk cursors for each corner, like Gdk.CursorType.BottomLeftCorner (examples are at https://developer.gnome.org/gdk/stable/gdk-Cursors.html).

Your bug from comment #2 should probably go into another bug report so that it doesn't get lost, since this issue is mainly about the cursor icons.

grofaty (grofaty) wrote :

Cameron, I understand your point. We should work more on icons to make them better - so multiple mouse icons for each of corners. I will try to create some icons, but probably I will do this in the future. I agree we should not hold down the Pinta 1.5 release because of icons redesign.

For #2 I have reported separate bug 1188924.

tags: added: selection-tools
grofaty (grofaty) wrote :

Cameron, I have been looking for #9 icons and as I understand we would need and icon for each of the corner.

I think we can reduce the number of icons if we use the same icons for left and right site (or top and bottom). I have created this icons now, can you look at them and provide a feedback?

grofaty (grofaty) wrote :
grofaty (grofaty) wrote :
grofaty (grofaty) wrote :
grofaty (grofaty) wrote :
grofaty (grofaty) wrote :
grofaty (grofaty) wrote :
grofaty (grofaty) wrote :
grofaty (grofaty) wrote :
grofaty (grofaty) wrote :

I created a print-screen of all new suggested resize icons to easily compare them.

Cameron White (cameronwhite91) wrote :

Those look good, but it might be worthwhile to see how the standard Gtk arrow icons look as well. I'm not sure if it's really necessary to have the rectangle/ellipse symbol in there for this case.

Changed in pinta:
milestone: none → 1.6
Changed in pinta:
importance: Undecided → Low
milestone: 1.6 → 1.7
status: New → Confirmed
Cameron White (cameronwhite91) wrote :

I've added in the standard resize cursors with https://github.com/PintaProject/Pinta/commit/81dfbc3b. IMO they look pretty good (on Windows, at least)

Changed in pinta:
assignee: nobody → Cameron White (cameronwhite91)
status: Confirmed → In Progress
grofaty (grofaty) wrote :

I tested on Windows and they are awesome, much better then hand icon. Hand icon looks like you want to move something and not resize. This new arrows make a feeling you gonna really resize.

I have reported similar bug 1419641 few weeks ago for other objects: Ellipse, Rectangle etc.

grofaty (grofaty) wrote :

Now I tried Pinta dev. 1.7.0.145 on Ubuntu 14.04 and I see there are not the same icons and on Windows. Is this intentional? I somehow like Windows icons, but Ubuntu icons are just looking so much more professional. Is it possible to get the same icons on both system?

Cameron White (cameronwhite91) wrote :

It's just using the standard resize cursors from the system, so we'd have to supply our own cursors instead if we wanted a consistent look across platforms. In this case, I think it's better to use the same cursors that users are familiar with seeing in every other application on their system.

Cameron White (cameronwhite91) wrote :

I guess this can be marked as Fix Committed now.

Changed in pinta:
status: In Progress → Fix Committed
summary: - Rectangle Select mouse icon automatically changed to Pan with no click
- action
+ Rectangle Select cursor is the same as the Pan cursor
grofaty (grofaty) wrote :

Yes, I agree, idea to have as close icons as usual on operating system is OK. Fix Commited status is fine. Thanks for fixing this "bug".

grofaty (grofaty) on 2020-08-05
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.