Escaping window if file type is not recognized

Bug #1048502 reported by grofaty on 2012-09-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Low
Cameron White

Bug Description

In Pinta-1.4-preview-20120908 on Windows XP testing bug 988278 and I have found another problem:
1. Open text editor and type in some text like: test
2. Save file in text editor, but name it: test.png
Note: I know this is text file, just want to test what happens if I open text file in Pinta.
3. File | Open and mark fake test.png file and click Open.
4. It opens an error message "Could not open file..."
5. Now switch to text editor (or any other program) and switch back to Pinta. The error message disappeared (actually hidden behind other windows) and it is impossible to continue to work in Pinta until all of the programs are minimized, to get "error message" window. This is classical "escaping window" problem. In my humble opinion, no window should escape main Pinta program. This is not a big problem for geeks, but for non-geeks this looks like Pinta has frozen, because it is not responding to clicks.

grofaty (grofaty) on 2012-09-10
tags: added: easy-to-fix
Cameron White (cameronwhite91) wrote :

I've pushed a fix for this: https://github.com/PintaProject/Pinta/commit/d76741ea9a1641ec434f16e20820ce709a38fd6d

This fixes issues with being able to close the Open File dialog while the error dialog was still open. However, I've never been able to reproduce the escaping window issue, so let me know if you need me to make a Windows build available to test this.

Changed in pinta:
assignee: nobody → Cameron White (cameronwhite91)
importance: Undecided → Low
milestone: none → 1.4
status: New → Fix Committed
grofaty (grofaty) wrote :

There is no need for special Windows build at the moment, because this is not huge problem. I will test this bug at next regular Pinta's Windows build and let you know.

grofaty (grofaty) wrote :

Tested in Pinta-1.4-preview-20120922 on Windows XP and I can confirm no more escaping Window, so this bug is fixed. Thanks.

grofaty (grofaty) on 2012-09-27
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers