Undo using CTRL+Z not working if this is first action in new image

Bug #1036041 reported by grofaty on 2012-08-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
High
Cameron White

Bug Description

Hi,
using pinta-1.4-preview-20120812 on Windows XP I tested bug https://bugs.launchpad.net/pinta/+bug/983709 which is almost fixed, but now I am opening a new bug, because I can't reproduce the bug in the same way as above bug (I can still reproduce on v1.3), so opening a new one to reduce confusion...

Test 1: Undo works fine with toolbar icon
1. Open Pinta
2. Select Paintbrush and draw something on canvas.
3. Select Text object, click on canvas and type in some text like: test
4. Click Undo button from toolbar. Works fine.

Test 2: Undo works fine with CTRL+Z if some other action was already performed
5. Continue from previous test. Click on canvas (Text object is selected from previous test) and type in some text like: test
6. Press CTRL+Z. Undo works fine.

Test 3: Undo does NOT work fine with CTRL+Z if first action in new image
1. Close image CTRL+W without saving it.
2. Open new image.
3. Select Text object from Tools, click on canvas and type in text like: test
4. Press CTRL+Z and you will notice nothing happens, so undo does not work.
P.S. As I see this time work-around is to press <ESC> key and then repeat CTRL+Z. But <ESC> key was not required in Test 2, and in my humble opinion it should not be required in this test too.

Cameron White (cameronwhite91) wrote :

This was fixed while working on re-editable text (in https://github.com/PintaProject/Pinta/pull/34), so I'll mark this as In Progress until that pull request is merged in.

Changed in pinta:
importance: Undecided → High
milestone: none → 1.4
status: New → In Progress
tags: added: text-tool
Cameron White (cameronwhite91) wrote :

I've committed the fix separately since this issue is targeted for v1.4, and the fix is independent from the changes made for re-editable text :
https://github.com/PintaProject/Pinta/commit/9e921f04867633c19924ef9f6c8cb856a8e62476

Changed in pinta:
assignee: nobody → Cameron White (cameronwhite91)
status: In Progress → Fix Committed
grofaty (grofaty) on 2012-09-27
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers