Drawing near the right or bottom edges causes the border to disappear

Bug #1015345 reported by Cameron White on 2012-06-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Medium
akshara proddatoori

Bug Description

This appears on the latest development version of Pinta, but not on Pinta 1.3. This was likely introduced by https://github.com/PintaProject/Pinta/pull/27, which added a drop shadow to the canvas.

Steps to reproduce:
1) Using the paintbrush tool, click and then drag beyond the right or bottom border.
2) Parts of the border have now disappeared. However, if you draw somewhere else on the canvas afterwards, the border usually reappears.

can anybody elaborate a little more on this bug...

Cameron White (cameronwhite91) wrote :

I can't seem to get a screenshot of this, because the border re-appears as soon as I press the Prt Sc key. Here are some more detailed steps:

1) Start drawing a line with the Paintbrush tool, and then (while drawing) move the mouse beyond the bottom right corner of the canvas.
2) The border shadow near the corner disappears.

You'll need to be running the latest development version of Pinta to see this, since the bug was introduced after the Pinta 1.3 release.

Changed in pinta:
assignee: nobody → akshara proddatoori (akshara-proddaturi)

can anyone please check the patch submitted...its works fine now..

Robert Nordan (rpvn) wrote :

Hey, sorry it took a while for one of us to respond. It's super cool that you fixed this! But we can't really do anything with a fix that is submitted as a plain unix diff, because a) there is no version control information in it that says which checkout from git you've made the changes from, b) it contains references to local file paths like "/home/akshara", and c) it also diffs lots of compiled files that don't go into version control. So we can't really do anything with a patch file like this, since it's too hard for us to see what you actually did to fix the problem. :-(

Therefore it would be really nice if you could follow the steps on this page: http://pinta-project.com/contribute.ashx#Patches_and_Fixes_7 :-) Once you have your changes available as a github pull request, we'd love to inspect them and merge them in! (Again, thanks for taking time to fix the problem, now we just need you to take a little more time to get it merged in!) ;-)

Cameron White (cameronwhite91) wrote :

I've committed Akshara's patch, with a couple modifications to reduce code duplication and fix the issue for the eraser tool as well (https://github.com/PintaProject/Pinta/commit/73b856af8560e2dbb340bac8e1547317a8b0f625).

Thanks!

Changed in pinta:
status: Confirmed → Fix Committed

am really sorry about the diff part....but thanks a lot for commiting the patch...it means a lot... :)

grofaty (grofaty) on 2012-09-27
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers