Shortcuts for Auto Level and Black and White adjustments are broken

Bug #1008557 reported by grofaty on 2012-06-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Pinta
Low
Cameron White

Bug Description

Latest development on Ubuntu 12.04 (the same problem in Pinta v1.3 on Windows so probably an old bug).

Click on Adjustments menu and you will notice that both options Adjustments | Auto Level and Adjustments | Black and White have the same shortcut specified. But when pressing <shift>+<ctrl>+L "Save Image As" dialog appears. So non of above options work. Just checking in Paint.NET and there is <shift>+<ctrl>+L for auto-level and <shift>+<ctrl>+G for black & white. Maybe assign the same shortcuts.

grofaty (grofaty) on 2012-06-06
tags: added: easy-to-fix
Cameron White (cameronwhite91) wrote :

Looks like Window/Save All is also set to Shift+Ctrl+L

Changed in pinta:
importance: Undecided → Low
status: New → Confirmed
grofaty (grofaty) wrote :

My suggestion:
- Adjustments | Auto-Level: <SHIFT>+<CTRL>+L
- Adjustments | Black and White: <SHIFT>+<CTRL>+G
- Window | Save All: <CTRL>+<ALT>+S

Cameron White (cameronwhite91) wrote :

Fixed: https://github.com/PintaProject/Pinta/commit/10ecf15b471768c5c03f3ba77fc1cdac18ed322f

It turns out that Ctrl+Alt+S is a system shortcut in Ubuntu, so I used Ctrl+Alt+A for Save All instead.

Changed in pinta:
assignee: nobody → Cameron White (cameronwhite91)
milestone: none → 1.4
status: Confirmed → Fix Committed
grofaty (grofaty) on 2012-09-27
Changed in pinta:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers