Doesn't launch

Bug #1035201 reported by Matthew Paul Thomas on 2012-08-10
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Picsaw
Undecided
Unassigned
Arch Linux
New
Undecided
Unassigned
openSUSE
New
Undecided
Unassigned

Bug Description

picsaw 1.0.1-0extras12.04.1, Ubuntu 12.04

1. Click Picsaw in the Launcher.

What happens: The icon throbs for a while, then stops. No window opens.

At a terminal, "/opt/extras.ubuntu.com/picsaw/bin/picsaw" uses 99% CPU but gives no output.

description: updated
Marguerite Su (i-5lmm) wrote :

I can confirm this bug in 1.0.2 and trunk version.

I built picsaw with openSUSE (12.2 RC2, gcc 4.7.1)

every process is okay, but you can't launch it.

in GDB, it hangs at

(gdb) run
Starting program: /usr/bin/picsaw
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0x7fffec15a700 (LWP 7945)]

by the way,

1. if you use the given "gcc -V" to build, it will complain "-V" & "-qversion" no such options, as well as missing "liblto_plugin.so" which is actually at /usr/lib64/gcc/x86_64-suse-linux/4.7

2. configure is missing "LIBS=-lm" option. without it, picsaw can't be built.

more information see Archlinux AUR and openSUSE OBS:

https://aur.archlinux.org/packages/pi/picsaw/PKGBUILD

https://build.opensuse.org/package/show?package=picsaw&project=home%3AMargueriteSu

Greetings,

Marguerite

Marguerite Su (i-5lmm) wrote :

I add Arch and openSUSE because the doesn't launch and gcc problems are both confirmed by users of these distros, as well as Chakra.

Marguerite Su (i-5lmm) wrote :

I don't know if this is helpful.

both occurs on 64 bit.

Cedara (cedara2) wrote :

Doesn't launch either in the 32-bit version on an AMD64 5600+

Cedara (cedara2) wrote :

Addendum: I meant ubuntu 12.04 32-bit.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments