installation stuck on undefined offset for error handler

Bug #537295 reported by darwin on 2010-03-11
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
PHPDevShell
High
Greg

Bug Description

after i do installation it stuck on this
Undefined offset: 8192 in C:\Program Files\EasyPHP5.3.0\www\orbytz-online.com_ver0.24\admin\system\includes\errorHandler.class.php on line 217
Fatal error: Exception thrown without a stack frame in Unknown on line 0

i try to fix it but i cant simply find where and why does it is stuck

darwin (darwin-liem) wrote :

i found the bug.... it wont work because of ereg_replace is no longer used in PHP5 so someone who understand regex please fix this... thanks a million

TitanKing (titan-phpdevshell) wrote :

Hi Darwin, PHPDevShell V3.0.0 is heavily developed and this bug will be fixed in this version.
Thanks for the bug report.

so i cant use your amazing tools until the version 3 is launched?

 Best Regards
Darwin Liem

________________________________
From: TitanKing <email address hidden>
To: <email address hidden>
Sent: Fri, March 12, 2010 12:09:14 PM
Subject: [Bug 537295] Re: installation stuck on undefined offset for error handler

Hi Darwin, PHPDevShell V3.0.0 is heavily developed and this bug will be fixed in this version.
Thanks for the bug report.

--
installation stuck on undefined offset for error handler
https://bugs.launchpad.net/bugs/537295
You received this bug notification because you are a direct subscriber
of the bug.

Status in Open Source php gui type development framework.: New

Bug description:
after i do installation it stuck on this
Undefined offset: 8192 in C:\Program Files\EasyPHP5.3.0\www\orbytz-online.com_ver0.24\admin\system\includes\errorHandler.class.php on line 217
Fatal error: Exception thrown without a stack frame in Unknown on line 0

i try to fix it but i cant simply find where and why does it is stuck

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/phpdevshell/+bug/537295/+subscribe

TitanKing (titan-phpdevshell) wrote :

No of coarse you can, just saying that this bug will be fixed anyways.

I will give you a fix for this within the next few minutes.

darwin (darwin-liem) wrote :

wow... you r the best of the best... I'm deeply in debt to you. Thanks a Million.

 Best Regards
Darwin Liem

________________________________
From: TitanKing <email address hidden>
To: <email address hidden>
Sent: Fri, March 12, 2010 1:40:56 PM
Subject: [Bug 537295] Re: installation stuck on undefined offset for error handler

No of coarse you can, just saying that this bug will be fixed anyways.

I will give you a fix for this within the next few minutes.

--
installation stuck on undefined offset for error handler
https://bugs.launchpad.net/bugs/537295
You received this bug notification because you are a direct subscriber
of the bug.

Status in Open Source php gui type development framework.: New

Bug description:
after i do installation it stuck on this
Undefined offset: 8192 in C:\Program Files\EasyPHP5.3.0\www\orbytz-online.com_ver0.24\admin\system\includes\errorHandler.class.php on line 217
Fatal error: Exception thrown without a stack frame in Unknown on line 0

i try to fix it but i cant simply find where and why does it is stuck

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/phpdevshell/+bug/537295/+subscribe

TitanKing (titan-phpdevshell) wrote :

Hi,

You have 2 options, either use a previous version of PHP before 5.3, or create a branch from this repository:
https://code.launchpad.net/~phpdevshell/phpdevshell/v2.8.2

If you dont know how to do either please let us know.

Greg (gregfr) wrote :

Actually ereg functions are deprecated but still usuable. So you have 2 possibilities :

- either silent the warnings ( error_reporting(0); )

- or change every (about 25) ereg with preg ; for example

./plugins/PHPDevShell/scripts/user-admin/user-admin-list.php (line 92):

     $extra_role_constant = ereg_replace(' ', '&nbsp;', $extra_role_db_array['user_role_name']);

replace by

     $extra_role_constant = preg_replace('/ /', '&nbsp;', $extra_role_db_array['user_role_name']);

not the syntax is slightly different, the pattern in preg_replace is surrounded by slashes.

greg

Changed in phpdevshell:
status: New → Fix Committed
assignee: nobody → Greg (gregfr)
darwin (darwin-liem) wrote :

hi,

first options i do know how to do it, but i think me and my team does not want to downgrade our php. for branch i dont think we want to do that either... whatever branch is means (sorry don't familiar with the terms). but thanks anyway greg have show me how to fix the ereg with preg... it simply adding / at the first regex pattern and the same also at the end / so i think i try that first.

 Best Regards
Darwin Liem

________________________________
From: TitanKing <email address hidden>
To: <email address hidden>
Sent: Fri, March 12, 2010 4:38:52 PM
Subject: [Bug 537295] Re: installation stuck on undefined offset for error handler

Hi,

You have 2 options, either use a previous version of PHP before 5.3, or create a branch from this repository:
https://code.launchpad.net/~phpdevshell/phpdevshell/v2.8.2

If you dont know how to do either please let us know.

--
installation stuck on undefined offset for error handler
https://bugs.launchpad.net/bugs/537295
You received this bug notification because you are a direct subscriber
of the bug.

Status in Open Source php gui type development framework.: New

Bug description:
after i do installation it stuck on this
Undefined offset: 8192 in C:\Program Files\EasyPHP5.3.0\www\orbytz-online.com_ver0.24\admin\system\includes\errorHandler.class.php on line 217
Fatal error: Exception thrown without a stack frame in Unknown on line 0

i try to fix it but i cant simply find where and why does it is stuck

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/phpdevshell/+bug/537295/+subscribe

darwin (darwin-liem) wrote :

hi,

thanks a million greg i think we will try your solution... if we manage to make it works... i'll send you a copy hope its help others who stumble on teh same problem with us.

 Best Regards
Darwin Liem

________________________________
From: Greg <email address hidden>
To: <email address hidden>
Sent: Fri, March 12, 2010 4:45:46 PM
Subject: [Bug 537295] Re: installation stuck on undefined offset for error handler

Actually ereg functions are deprecated but still usuable. So you have 2
possibilities :

- either silent the warnings ( error_reporting(0); )

- or change every (about 25) ereg with preg ; for example

./plugins/PHPDevShell/scripts/user-admin/user-admin-list.php (line 92):

     $extra_role_constant = ereg_replace(' ', '&nbsp;',
$extra_role_db_array['user_role_name']);

replace by

     $extra_role_constant = preg_replace('/ /', '&nbsp;',
$extra_role_db_array['user_role_name']);

not the syntax is slightly different, the pattern in preg_replace is
surrounded by slashes.

greg

** Changed in: phpdevshell
       Status: New => Fix Committed

** Changed in: phpdevshell
     Assignee: (unassigned) => Greg (gregfr)

--
installation stuck on undefined offset for error handler
https://bugs.launchpad.net/bugs/537295
You received this bug notification because you are a direct subscriber
of the bug.

Status in Open Source php gui type development framework.: Fix Committed

Bug description:
after i do installation it stuck on this
Undefined offset: 8192 in C:\Program Files\EasyPHP5.3.0\www\orbytz-online.com_ver0.24\admin\system\includes\errorHandler.class.php on line 217
Fatal error: Exception thrown without a stack frame in Unknown on line 0

i try to fix it but i cant simply find where and why does it is stuck

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/phpdevshell/+bug/537295/+subscribe

darwin (darwin-liem) wrote :

hi,

i know hoe to change ereg_replace to preg_replace as you instructed and i find how to chnage eregi_replace with addition /i on the last patern.... but how to change ereg() ? preg_match()?

 Best Regards
Darwin Liem

________________________________
From: Greg <email address hidden>
To: <email address hidden>
Sent: Fri, March 12, 2010 4:45:46 PM
Subject: [Bug 537295] Re: installation stuck on undefined offset for error handler

Actually ereg functions are deprecated but still usuable. So you have 2
possibilities :

- either silent the warnings ( error_reporting(0); )

- or change every (about 25) ereg with preg ; for example

./plugins/PHPDevShell/scripts/user-admin/user-admin-list.php (line 92):

     $extra_role_constant = ereg_replace(' ', '&nbsp;',
$extra_role_db_array['user_role_name']);

replace by

     $extra_role_constant = preg_replace('/ /', '&nbsp;',
$extra_role_db_array['user_role_name']);

not the syntax is slightly different, the pattern in preg_replace is
surrounded by slashes.

greg

** Changed in: phpdevshell
       Status: New => Fix Committed

** Changed in: phpdevshell
     Assignee: (unassigned) => Greg (gregfr)

--
installation stuck on undefined offset for error handler
https://bugs.launchpad.net/bugs/537295
You received this bug notification because you are a direct subscriber
of the bug.

Status in Open Source php gui type development framework.: Fix Committed

Bug description:
after i do installation it stuck on this
Undefined offset: 8192 in C:\Program Files\EasyPHP5.3.0\www\orbytz-online.com_ver0.24\admin\system\includes\errorHandler.class.php on line 217
Fatal error: Exception thrown without a stack frame in Unknown on line 0

i try to fix it but i cant simply find where and why does it is stuck

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/phpdevshell/+bug/537295/+subscribe

Greg (gregfr) wrote :

Yes preg_match should be used instead of ereg().

Regarding the "branch" it's actually the version we add features to everyday. If you're new to PHPDS, and/or plan to heavily develop on this base, I suggest you give it a try, since it's core components have changed a lot. it's pretty easy, take a look at "bazaar explorer" you should be able to retreive the files easily

Greg (gregfr) wrote :

I think actually it's because we can't throw an exception inside an error handler. I need to study that closer.

Changed in phpdevshell:
status: Fix Committed → Confirmed
Greg (gregfr) wrote :

The error handler should now be cleaner and avoid such situations

Changed in phpdevshell:
status: Confirmed → Fix Committed
importance: Undecided → High
Changed in phpdevshell:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers