Windows: Geek action treats whole string as program name (once)

Bug #704204 reported by BW on 2011-01-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Phatch
Undecided
Unassigned

Bug Description

This only applies to Phatch for Windows

The first time an action list is run with a geek command that has been changed, the batch fails with "Can not apply action Geek: No such program", printing the entire geek command string. This happens regardless of whether any verification options are set.

Steps to replicate:
run Phatch for Windows
Add a geek command (works whether this is the last action or not).
Try to run a batch.

After you click OK, future batches will run perfectly until you edit the command, after which you have a single failure once more.

Stani (stani) wrote :

> This only applies to Phatch for Windows.
Did you try this on Linux or Mac?

Please also provide an example action list with a geek action, so we have a reproducable test case. Without test case this bug will remain with the status incomplete.

Changed in phatch:
status: New → Incomplete
BW (bwbiztemp) wrote :

Oh right, sorry!

On testing, the attached list triggers the error on the first attempt, but if it does not, try editing the command string to one of the defaults.

BW (bwbiztemp) on 2011-01-19
Changed in phatch:
status: Incomplete → New
Val (vk1266) wrote :

Phatch 0.2.7 in Linux: Ubuntu 12.04 AMD64 has the same bug.

DalaiDakkar (dalaidakkar) wrote :

this happens also on ARCHLINUX version of phatch, only the 1st run, next runs works fine

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers