[Mac] Library dialog is not ok

Bug #526057 reported by Stani on 2010-02-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Phatch
Low
Stani

Bug Description

- select button does not have enough space around it
- size should be adjusted so 2 rows are shown

The relevant code for the space around the button is in lib/pyWx/imageFileBrowser.py (line 115):
        #buttons
        btn_sizer = wx.BoxSizer(wx.HORIZONTAL)
        b = 6
        btn_sizer.Add(self.status, 1, wx.ALL | wx.ALIGN_CENTER_VERTICAL, b)
        btn_sizer.Add(self.cancel, 0, wx.ALL | wx.ALIGN_CENTER_VERTICAL, b)
        btn_sizer.Add(self.ok, 0, wx.ALL | wx.ALIGN_CENTER_VERTICAL, b)
        sizer.Add(btn_sizer, 0, wx.EXPAND, 0)

Now the space should be 6px as specified by 'b=6'. To increase the size give a higher value

The relevant code for the size is in pyWx/gui.py (line 645):
            self.dlg_library = imageFileBrowser.Dialog(
                parent=self,
                files=self.library_files_dictionary,
                title=_('Library Action Lists'),
                size=(self.GetSize()[0], 370),
                icon_size=(128, 128))
       (...)

-> You need to replace 370 with a higher value until two rows of thumbnails are visible. So what is this value?

Please attach a screenshot so I can evaluate the result.

Thanks!

Tags: mac Edit Tag help
Stani (stani) on 2010-02-22
Changed in phatch:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → stani (stani)
Stani (stani) on 2010-02-25
Changed in phatch:
assignee: stani (stani) → Gregory Meno (greg-meno)
milestone: none → 0.2.7
Stani (stani) on 2010-02-28
Changed in phatch:
milestone: 0.2.7 → 0.2.8
Stani (stani) on 2010-03-02
Changed in phatch:
assignee: Gregory Meno (greg-meno) → nobody
Stani (stani) on 2010-03-04
description: updated
description: updated
Stani (stani) on 2010-03-05
tags: added: mac
robinmills (robinmills) on 2010-03-10
Changed in phatch:
assignee: nobody → clanmills (robinmills)
robinmills (robinmills) wrote :

Insufficient information.

I'm not sure what the Library dialog is. I enclose screen shots of three windows which are clearly in need of attention:

Inspector.jpg: I think this is the one being discussed. It looks 'kind of' all right. I'm not sure why the Exif tags have a P in front of them - maybe that's by design.

Ready.jpg: This is basically OK. However it appears at the top left of the screen. I think it should be a sheet coming out of the main application window.

Inspector.jpg: This needs a lot of attention.
1) I think it should also be a sheet coming out of the main phatch window. Throwing it up in the top left of the screen feels very strange.
2) Clearly sizing (and possibly location) issues with the "Continue" button.
3) Search box is overlapping the browser control below.
4) The browser control is very boring (I don't know if that's a bug - it's just the way it looks to me).

I seem to be only about to upload attachments one at a time. I'll add the others. I'll run the same actionlist on Linux and Windows and post the screen shots for comparison.

Stani: I'm sure you'll want to separate all those bugs - however let them just collect here for the moment. We can discuss what to do about them in a day or two. We have to start somewhere.

robinmills (robinmills) wrote :
robinmills (robinmills) wrote :
robinmills (robinmills) wrote :
robinmills (robinmills) wrote :
robinmills (robinmills) wrote :
robinmills (robinmills) wrote :

I'm going to bed now. I'll see if I can get 0.2.7.1 running on Windows 7 tomorrow and see how it looks. I also have a 64 Vista Ultimate and 32 bit XP system. Let's see where we are with that lot on Sunday. I have promised to proof read the first 20 pages of a User Manual on Sunday, talk with Nadia (and I hope Andre), and go running with Dennis. Patience - I'm working on this stuff. Thank goodness I don't have work this week - I don't have time to waste earning a living!

Stani (stani) wrote :

@robin

Sorry for being unclear. The library dialog is of course the one which you get with File>Open Library

Stani (stani) wrote :

@robin

Of course I mean from the menu 'Action List>Open Library...'

Stani (stani) on 2010-03-15
Changed in phatch:
assignee: robinmills (robinmills) → Stani (stani)
status: Confirmed → Fix Committed
Stani (stani) on 2010-03-17
Changed in phatch:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers