[Mac] Execute dialog is cramped in Mac OS X

Bug #516858 reported by Nadia Alramli on 2010-02-04
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Phatch
Low
Stani

Bug Description

A screenshot is attached

Nadia Alramli (nadiana) wrote :
Stani (stani) on 2010-02-23
Changed in phatch:
milestone: none → 0.2.7
Stani (stani) wrote :

Hi Greg,

You have a Mac right? Could you take care of this? It is pretty simple, fill the right width in phatch/pyWx/dialogs.py (line 132):

class ExecuteDialog(BrowseMixin, dialogs.ExecuteDialog):

    def __init__(self, parent, drop=False, **options):
        super(ExecuteDialog, self).__init__(parent, -1, **options)
        self.set_drop(drop)
        # width needs to be corrected manually as it is set too small
        if wx.Platform == '__WXGTK__':
            width = 600
        elif wx.Platform == '__WXMAC__':
            width = 450 #<----CHANGE THIS HERE!!
        else:
            width = 450
        self.SetSize((width, self.GetSize()[1]))

Create a new branch for it and attach a screenshot here of the result. Thanks!

Changed in phatch:
assignee: nobody → Gregory Meno (greg-meno)
Stani (stani) on 2010-02-25
Changed in phatch:
status: Confirmed → In Progress
Stani (stani) on 2010-02-28
summary: - Execute dialog is cramped in Mac OS X
+ [Mac] Execute dialog is cramped in Mac OS X
Stani (stani) wrote :

I guess I fixed this.

@Gregory, Nadia, Robin: Can someone of you confirm this?

Changed in phatch:
assignee: Gregory Meno (greg-meno) → stani (stani)
status: In Progress → Fix Committed

Looks good, see attachment.

On Sun, Feb 28, 2010 at 11:54 AM, stani <email address hidden> wrote:
> I guess I fixed this.
>
> @Gregory, Nadia, Robin: Can someone of you confirm this?
>
> ** Changed in: phatch
>       Status: In Progress => Fix Committed
>
> ** Changed in: phatch
>     Assignee: Gregory Meno (greg-meno) => stani (stani)
>
> --
> [Mac] Execute dialog is cramped in Mac OS X
> https://bugs.launchpad.net/bugs/516858
> You received this bug notification because you are a bug assignee.
>
> Status in Phatch = Photo & Batch!: Fix Committed
>
> Bug description:
> A screenshot is attached
>
>
>

Stani (stani) wrote :

@Greg
Great! Thanks for confirming this. Could you attack the library dialog? It is just a matter of setting the right size:
https://bugs.launchpad.net/phatch/+bug/526057

Very simple, but hard to do without a Mac ;-)

Stani (stani) on 2010-03-17
Changed in phatch:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers