Unable to extract variables from file

Bug #481751 reported by Lu Timdale on 2009-11-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Phatch
High
Stani
phatch (Ubuntu)
Undecided
Stani

Bug Description

I'm trying to import a few files in Phatch 0.2.4 in Karmic 9.10 64 bit.

I get the following error:
Traceback (most recent call last):
  File "/usr/share/phatch/phatch/core/api.py", line 489, in get_photo
    photo = pil.Photo(info_file, info_not_file)
  File "/usr/share/phatch/phatch/core/pil.py", line 464, in __init__
    layer.image)
  File "/usr/share/phatch/phatch/core/pil.py", line 214, in __init__
    raise Exception(message)
Exception: Unable extract variables from file:/home/lu/Pictures/DRTest/DSC_0080.JPG:
Key must be of type string
*
Error 1:Unable to open file: /home/lu/Pictures/DRTest/DSC_0180.JPG:
Unable extract variables from file:/home/lu/Pictures/DRTest/DSC_0180.JPG:
Key must be of type string

I can definitely see the exif stuff as part of the image... not sure what this is about.
I'm only using the basic save action and this for the Filename: <filename> <Exif_Photo_DateTimeOriginal.year>

Stani (stani) wrote :

Please attach example action list and image, so I can debug it.

Changed in phatch:
assignee: nobody → stani (stani)
status: New → Incomplete
Lu Timdale (lutimdale) wrote :

Image is attached

Lu Timdale (lutimdale) wrote :

Action list is attached

Paillomams (aymeric-pallottini) wrote :

I get the same error when trying to rename a photo with Exif data. It was working fine with Ubuntu 9.04 but with 9.10 I get this message:

Error 0:Impossible d'ouvrir le fichier: /home/aymeric/Bureau/test.JPG:
Unable extract variables from file:/home/aymeric/Bureau/test.JPG:
Key must be of type string

Traceback (most recent call last):
  File "/usr/share/phatch/phatch/core/api.py", line 489, in get_photo
    photo = pil.Photo(info_file, info_not_file)
  File "/usr/share/phatch/phatch/core/pil.py", line 464, in __init__
    layer.image)
  File "/usr/share/phatch/phatch/core/pil.py", line 214, in __init__
    raise Exception(message)
Exception: Unable extract variables from file:/home/aymeric/Bureau/test.JPG:
Key must be of type string
*

Stani (stani) wrote :

Thanks to your examples, I can reproduce the bug.I'ĺl try to fix it.

Changed in phatch:
status: Incomplete → Confirmed
importance: Undecided → High
status: Confirmed → In Progress
milestone: none → 0.2.5
Stani (stani) wrote :

This is fixed in the bzr trunk and will be part of next release.

However in order to use https://bugs.launchpad.net/phatch/+bug/492665, you'll need to enable the unsafe mode (Tools>Unsafe Mode...) until I've fixed this bug:
https://bugs.launchpad.net/phatch/+bug/492665

Changed in phatch:
status: In Progress → Fix Committed
Stani (stani) on 2009-12-10
Changed in phatch (Ubuntu):
assignee: nobody → stani (stani)
status: New → In Progress
Stani (stani) on 2009-12-12
Changed in phatch:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package phatch - 0.2.5-1

---------------
phatch (0.2.5-1) unstable; urgency=low

  [ Stani M ]
  * Upstream bugfix release (Closes LP: #454426, #458366, #469231, #481751,
    #492665)
  * debian/watch: updated new location

  [ Bernd Zeimetz ]
  * debian/control:
    - Removing myself from Uploaders.
 -- Ubuntu Archive Auto-Sync <email address hidden> Tue, 22 Dec 2009 04:01:42 +0000

Changed in phatch (Ubuntu):
status: In Progress → Fix Released
Paillomams (aymeric-pallottini) wrote :

Is this package (Phatch 0.2.5.1) going to be available in Karmic? For the moment it seems to be available only in the Lucid repository.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers