Phatch package for karmic in the PPA has upgrade conflicts with the package in karmic itself

Bug #439938 reported by Jan Claeys on 2009-10-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Phatch
Medium
Stani

Bug Description

The Phatch package for karmic in the PPA has upgrade conflicts with the package in karmic itself, because in Karmic the application is split up into 4 packages. This happens both for older PPA versions --> Karmic version & Karmic version --> newer PPA versions.

It might be useful to use the packaging as used in Karmic instead of the current PPA packaging style?

Revision history for this message
Stani (stani) wrote :

Thanks for reporting this bug. I will investigate it.

Changed in phatch:
assignee: nobody → stani (stani)
milestone: none → 0.2.2
Stani (stani) on 2009-10-02
Changed in phatch:
milestone: 0.2.2 → 0.2.3
Revision history for this message
Stani (stani) wrote :

For now I disabled Karmic in my PPA, as we are pushing our updates immediately through the official Karmic channel.

Stani (stani) on 2009-10-11
Changed in phatch:
milestone: 0.2.3 → none
Stani (stani) on 2009-10-11
Changed in phatch:
importance: Undecided → Medium
status: New → Confirmed
milestone: none → 0.2.4
Stani (stani) on 2009-10-15
Changed in phatch:
milestone: 0.2.4 → none
milestone: none → 0.2.5
Revision history for this message
Stani (stani) wrote :

After some thoughts, I chose consciously to not do the same packaging in the PPA as I do for the debian/Ubuntu repositories. There are three reasons:
- one deb file is more easy to download/install to try out the latest features
- in ppa all plugins (including blender and inkscape) are enabled by default, so dependencies are configured differently in the packaging
- the packaging in karmic will break compatibility with previous ubuntu versions (such as hardy and so on ...)

I'm now doing research how to package into one file without conflicts.

Changed in phatch:
status: Confirmed → In Progress
Revision history for this message
Stani (stani) wrote :

From now on the packages in the PPA are properly configured. I've updated the PPA description:

After adding the PPA and its key, you need to explicitly install phatch (dist-upgrade won't work):
   sudo apt-get update
   sudo apt-get install phatch

Changed in phatch:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers