Cannot resize action progress window

Bug #288404 reported by Emilio Pozuelo Monfort on 2008-10-23
2
Affects Status Importance Assigned to Milestone
Phatch
Wishlist
Stani

Bug Description

Using phatch 0.1.5

I'm unable to resize the action progress window, which makes impossible to see
the name of the files being processed, or even the window title.

I'm attaching a screenshot.

Stani (stani) wrote :

Hi Emilio,
Good to see you using Phatch. Unfortunately the progress dialog is a predefined wx dialog and I don't find a way to make it resizable. I'll ask on the wxpython mailing list to know for sure.

Changed in phatch:
assignee: nobody → stani
importance: Undecided → Wishlist
status: New → Confirmed
Stani (stani) wrote :

It seems to be a bug in wxpython:
http://article.gmane.org/gmane.comp.python.wxpython/64483

I 'fixed' it in Phatch by forcing Phatch progress dialog box not to start with an empty string. It is available from bazaar.

$ bzr diff
=== modified file 'phatch/core/api.py'
--- phatch/core/api.py 2008-04-05 19:23:49 +0000
+++ phatch/core/api.py 2008-10-29 13:22:04 +0000
@@ -347,7 +347,7 @@
     send.frame_show_progress( title = _("Executing action list"),
                                 parent_max = len(image_files),
                                 child_max = actions_amount,
- message = _('Starting...'),
+ message = '',
                             )

     for image_index, (folder,image_file) in enumerate(image_files):

=== modified file 'phatch/pyWx/dialogs.py'
--- phatch/pyWx/dialogs.py 2008-02-27 21:42:37 +0000
+++ phatch/pyWx/dialogs.py 2008-10-29 13:23:20 +0000
@@ -253,6 +253,8 @@
 class ProgressDialog(wx.ProgressDialog,ProgressReceiver):
     """+1 is added because eg opening a file is also an action"""
     def __init__(self,parent,title,parent_max=1,child_max=1,message=''):
+ if message == '':
+ message = '.'*80
         ProgressReceiver.__init__(self,parent_max,child_max)
         wx.ProgressDialog.__init__(self,
                 title = title,
$ bzr commit -m "fix small progress dialog box"
Committing to: /home/stani/sync/python/phatch/trunk/
modified phatch/core/api.py
modified phatch/pyWx/dialogs.py
Committed revision 541.

I filed a bug report about it:
http://trac.wxwidgets.org/ticket/10128

However my patch solves the usability issue.

Changed in phatch:
status: Confirmed → Fix Committed
Stani (stani) on 2008-12-01
Changed in phatch:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.