no longer starts (Exception: fromstring() has been removed.)

Bug #1538906 reported by Rory on 2016-01-28
This bug affects 15 people
Affects Status Importance Assigned to Milestone

Bug Description

thatch used to work for me (fedora 20 I believe). But now I install it, and it shows the eye and nothing more.

here's the console output:

/usr/lib/python2.7/site-packages/phatch/lib/ PyGIWarning: Notify was imported without specifying a version first. Use gi.require_version('Notify', '0.7') before import to ensure that the right version gets loaded.
  import gi.repository.Notify as pynotify
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/", line 16762, in <lambda>
    lambda event: event.callable(*event.args, ** )
  File "/usr/lib/python2.7/site-packages/phatch/pyWx/", line 1218, in show_frame
    frame = Frame(self.filename, None, -1, ct.TITLE)
  File "/usr/lib/python2.7/site-packages/phatch/pyWx/", line 327, in __init__
    frame.Frame.__init__(self, *args, **keyw)
  File "/usr/lib/python2.7/site-packages/phatch/pyWx/wxGlade/", line 141, in __init__
  File "/usr/lib/python2.7/site-packages/phatch/pyWx/wxGlade/", line 26, in __init__
    set_dirty = parent.set_dirty,
  File "/usr/lib/python2.7/site-packages/phatch/lib/pyWx/", line 96, in __init__
  File "/usr/lib/python2.7/site-packages/phatch/lib/pyWx/", line 111, in CreateImageList
    self._AddFormToImageList(form, icon_size, icon_disabled)
  File "/usr/lib/python2.7/site-packages/phatch/lib/pyWx/", line 120, in _AddFormToImageList
    wx_image = pil_wxImage(wxImage_pil(wx_image).resize(icon_size,\
  File "/usr/lib/python2.7/site-packages/phatch/lib/pyWx/", line 46, in wxImage_pil
  File "/usr/lib64/python2.7/site-packages/PIL/", line 737, in fromstring
    "Please call frombytes() instead.")
Exception: fromstring() has been removed. Please call frombytes() instead.

Nizar Kerkeni (nizarus) wrote :

I have the same issue with xenial 64 bits.

Pierantonio (pborga) wrote :

Me too: I have the same issue with xenial 64 bits. Tks

Paillomams (aymeric-pallottini) wrote :

Same issue after xenial 64 bits upgrade from 15.10

This bug can be solved applying the patch described in:

The file to be modified is:

CANTE Pierre (pierrecante) wrote :

I confirm that Magnus Berg has solved the problem :
Here phatch is working now with the new file

Paillomams (aymeric-pallottini) wrote :

Solved for me too

NoBugs (nobugs-ubuntu) wrote :

Yes problem solved, thank you, when will this be applied to repository?

shemgp (shemgp) wrote :

Here's a debdiff fix using a reverse patch of patch in #4. I could not use bzr lp-propose as it says:
bzr: ERROR: source package has no branch.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.