Percona XtraDB Storage Engine for MySQL

ANALYZE TABLE doesn't anything when innodb_stats_on_metadata=OFF

Reported by Yasufumi Kinoshita on 2010-02-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona-XtraDB
Fix Released
Medium
Unassigned
Percona patches
Fix Released
Undecided
Unassigned

Bug Description

ANALYZE TABLE command seems not to do anything when
innodb_stats_on_metadata=OFF

Changed in percona-xtradb:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Yasufumi Kinoshita (yasufumi-kinoshita)
Changed in percona-xtradb:
status: Confirmed → Fix Committed
Changed in percona-patches:
status: New → Fix Committed

Yasufumi,

Can we have mysql-test for this bug ?

On Mon, Feb 15, 2010 at 2:21 AM, Yasufumi Kinoshita
<email address hidden> wrote:
> http://bazaar.launchpad.net/~percona-dev/percona-xtradb/extensions-1.0.6/revision/146
> http://bazaar.launchpad.net/~percona-dev/percona-patches/5.1.43/revision/19
> fix were committed
>
>
> ** Changed in: percona-xtradb
>       Status: Confirmed => Fix Committed
>
> ** Changed in: percona-patches
>       Status: New => Fix Committed
>
> --
> ANALYZE TABLE doesn't anything when innodb_stats_on_metadata=OFF
> https://bugs.launchpad.net/bugs/520825
> You received this bug notification because you are a member of Percona
> developers, which is the registrant for Percona patches.
>
> Status in Patches for MySQL by Percona: Fix Committed
> Status in Percona XtraDB Storage Engine for MySQL: Fix Committed
>
> Bug description:
> ANALYZE TABLE command seems not to do anything when
> innodb_stats_on_metadata=OFF
>
>
>

--
Vadim Tkachenko, CTO, Percona Inc.
Phone +1-888-401-3403, Skype: vadimtk153
Schedule meeting: http://tungle.me/VadimTkachenko

Stewart Smith (stewart) wrote :

All development of XtraDB has moved under the Percona Server project - https://launchpad.net/percona-server - If this bug can be reproduced against current Percona Server, please file this bug against percona-server (you can simply do so by using the "Also affects project" link above).

Thanks,
Stewart Smith
Director of Server Development
Percona.

Changed in percona-xtradb:
status: Fix Committed → Fix Released
Changed in percona-patches:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers