xtrabackup SST netcat "-d" option not available on Debian Squeeze

Bug #959970 reported by Chris Boulton on 2012-03-20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Percona XtraDB Cluster moved to https://jira.percona.com/projects/PXC
Fix Released
Ignacio Nin

Bug Description

When using the xtrabackup SST on a Debian Squeeze based system, the SST will error out with an error similar to the below:
120320 2:19:18 [ERROR] WSREP: Process completed with error: wsrep_sst_xtrabackup 'joiner' '' '' '/var/lib/mysql/' '/etc/mysql/my.cnf' '31891' 2>sst.err: 2 (No such file or directory)

sst.err contains the actual error message:
~$# cat /var/lib/mysql/sst.err
nc: invalid option -- 'd'
nc -h for help
tar: This does not look like a tar archive
tar: Exiting with failure status due to previous errors

A quick look at the man page for nc on Debian Squeeze shows the -d flag does not exist.

(I've removed -d from the SST script, but the transfer still doesn't seem to want to work. Have not investigated why yet)

Chris Boulton (chris.boulton) wrote :

Looks like netcat on Debian (squeeze - 1.10) also requires the listening port to be specified with -p, instead of just passing it to nc.

I've still not got the xtrabackup SST working, but am still digging.

Chris Boulton (chris.boulton) wrote :

So it looks like we just need to make sure we're using the OpenBSD version of netcat. Once it's installed and update-alternative'd, SST transfers are happening.

Chris Boulton (chris.boulton) wrote :

(as in netcat-openbsd on Debian/Ubuntu)

Changed in percona-xtradb-cluster:
assignee: nobody → Ignacio Nin (ignacio-nin)
Ignacio Nin (ignacio-nin) wrote :

Percona-XtraDB-Cluster-server changed to depend on netcat-openbsd in debian and ubuntu. Bug #960569 created to make it compatible with any netcat, which is more desirable.

Changed in percona-xtradb-cluster:
importance: Undecided → High
status: New → Fix Committed
guly (guly) wrote :

bzr branch lp:percona-xtradb-cluster two hours ago, bug still present. could you please link the commit?

Changed in percona-xtradb-cluster:
status: Fix Committed → Fix Released

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXC-941

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers