Percona XtraDB Cluster - HA scalable solution for MySQL

Percona-XtraDB-Cluster-shared conflicts with Percona-Server-shared-51

Reported by Mike rapuano on 2012-03-05
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Percona XtraDB Cluster
High
Ignacio Nin

Bug Description

[In:How to setup 3 node cluster in EC2 enviroment]

Used the same AMI: ami-250e5060

but its version 6.2 now and doing the basic yum install it failed:

yum install Percona-XtraDB-Cluster-server Percona-XtraDB-Cluster-client

--> Finished Dependency Resolution
Error: Percona-XtraDB-Cluster-shared conflicts with Percona-Server-shared-51
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Jeremy Dunn (innerspacesuit) wrote :

I'm experiencing the same issue using a Rackspace cloud server running CentOS release 6.2 (Final)

Vadim Tkachenko (vadim-tk) wrote :

We are working to set repository and packages with proper dependencies

Changed in percona-xtradb-cluster:
importance: Undecided → High
status: New → Confirmed
status: Confirmed → In Progress
tags: added: pkg
Changed in percona-xtradb-cluster:
assignee: nobody → Ignacio Nin (ignacio-nin)

Can someone give this bug a proper description please? In my email it's
just showing up as [DOC].

summary: - [DOC]
+ Percona-XtraDB-Cluster-shared conflicts with Percona-Server-shared-51
Elijah Paul (elijah-paul) wrote :

I managed to resolve this by installing the Percona shared-compat package:

# yum install Percona-Server-shared-compat.x86_64

Changed in percona-xtradb-cluster:
status: In Progress → Fix Released
Ritesh Gurung (ritesh-gurung) wrote :

While installing the Percona client and server on Centos 62 I faced the same error again and again

Skip-broken could not solve problems
Error: Percona-XtraDB-Cluster-server conflicts with Percona-Server-server-55
Error: Percona-XtraDB-Cluster-client conflicts with Percona-Server-client-55

Even after specifying yum install --skip-broken Percona-Server-client-55 Percona-Server-server-55
I am getting same error. Any help would really be appreciated

Ignacio Nin (ignacio-nin) wrote :

Hello Ritesh,

Percona Server and Percona XtraDB Cluster intentionally conflict, since they provide the same files and services. For RPM-based platforms, you need to yum uninstall Percona Server first.

Regards!

Khushil Dep (khushil-dep) wrote :

yum install Percona-Server-client-55.x86_64 Percona-Server-server-55.x86_64
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.steadfast.net
 * epel: mirror.seas.harvard.edu
 * extras: mirror.net.cen.ct.gov
 * ius: mirrors.ircam.fr
 * updates: mirror.cs.vt.edu
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package Percona-Server-client-55.x86_64 0:5.5.24-rel26.0.256.rhel5 set to be updated
--> Processing Dependency: Percona-Server-shared-55 for package: Percona-Server-client-55
---> Package Percona-Server-server-55.x86_64 0:5.5.24-rel26.0.256.rhel5 set to be updated
--> Running transaction check
---> Package Percona-Server-shared-55.x86_64 0:5.5.24-rel26.0.256.rhel5 set to be updated
--> Processing Conflict: mysql conflicts MySQL
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package Percona-XtraDB-Cluster-client.x86_64 1:5.5.24-23.6.340.rhel5 set to be updated
--> Processing Conflict: Percona-XtraDB-Cluster-client conflicts Percona-Server-client-55
--> Finished Dependency Resolution
1:Percona-XtraDB-Cluster-client-5.5.24-23.6.340.rhel5.x86_64 from percona has depsolving problems
  --> Percona-XtraDB-Cluster-client conflicts with Percona-Server-client-55
Error: Percona-XtraDB-Cluster-client conflicts with Percona-Server-client-55
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

Confused about why it's trying to install XtraDB when I didn't ask it to?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers