5.6.37-26.21 not join the cluster

Bug #1732419 reported by Erman on 2017-11-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona XtraDB Cluster moved to https://jira.percona.com/projects/PXC
Invalid
Undecided
Erman

Bug Description

Hi,

In my environment, I have 3 active nodes. Percona versions of active nodes are 5.6.36-26.20.1.el7.x86_64.
I want to add a new node to this cluster. Percona version of new node is 5.6.37-26.21.3.el7.x86_64. I configured the my.cnf file in several times. But the new node can't join the cluster. Is there any dependencies about adding node with new percona version ?

I attached the error log of the new node when the mysql service starting.

Thanks,
Erman

Erman (ibrisim) wrote :
Erman (ibrisim) wrote :

Problem solved. It's not about percona versions. Here is the error message.

2017-11-15 14:24:04 4608 [ERROR] WSREP: wsrep_load(): dlopen(): /usr/lib64/galera3/libgalera_smm.so: symbol SSL_COMP_free_compression_methods, version libssl.so.10 not defined in file libssl.so.10 with link time reference
2017-11-15 14:24:04 4608 [ERROR] WSREP: wsrep_load(/usr/lib64/galera3/libgalera_smm.so) failed: Invalid argument (22). Reverting to no provider.

I upgraded the openssl package on the system.

Changed in percona-xtradb-cluster:
assignee: nobody → Erman (ibrisim)
status: New → Invalid

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXC-2018

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments