Incorrect definition of table performance_schema.global_variables

Bug #1726358 reported by John M on 2017-10-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona XtraDB Cluster moved to https://jira.percona.com/projects/PXC
Invalid
Undecided
Unassigned

Bug Description

After some upgrade of Percona, this message appeared in our logs(all 18 nodes, 6 clusters):

[ERROR] Incorrect definition of table performance_schema.global_variables: expected column 'VARIABLE_VALUE' at position 1 to have type varchar(2048), found type varchar(1024).

So we cant read from table global_variables: #1682 - Native table 'performance_schema'.'global_variables' has the wrong structure. (probably this is cause of situation, that we didnt se any cluster related charts in Percona Monitoring and Managment.)

Krunal Bauskar (krunal-bauskar) wrote :

Probably you missed running mysql_upgrade post moving to PXC.

John M (jan.m) wrote :

No, we started with clean PXC installation (Debian Wheezy). I also tried to run mysql_upgrade and restart all nodes of cluster, but nothing changed.

Krunal Bauskar (krunal-bauskar) wrote :

"After some upgrade of Percona" .... i failed to understand what upgrade you are talking about.

Clean installation shouldn't have this issue provided un-installation was complete and all dependencies were removed and re-installed properly.

John M (jan.m) wrote :

Sorry, I mean after some regular update from Percona repository.

We started with clean PXC on Debian Wheezy and performed only updates from your official deb repo(apt-get update & upgrade).

We use virtualization and these nodes were dedicated for PXC only, so clean system with PXC & PMM client after some updates became this state. There must be some bug(maybe in packaging for Wheezy), because this error appeared on in all our clustered dbs(~6).

Krunal Bauskar (krunal-bauskar) wrote :

That's weird now. We test these scenarios and haven't discovered it yet.

Let me re-iterate flow one more time:

* Install 5.6.x on Debian-wheezy. (This will replicate your existing setup)

* Upgrade packages to 5.7.x through apt-get update & upgrade.

* I presume "mysql_upgrade" execution was successful and it was done as instructed in non-cluster mode.

* When you restarted the said node in cluster mode it emitted the said error.

Did I captured the flow correctly ?

John M (jan.m) wrote :

I run mysql_upgrade again as described in latest upgrade guide and everything works fine now. So probably just my fault when upgrading clusters. Sorry for invalid bug.

Changed in percona-xtradb-cluster:
status: New → Invalid

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXC-2012

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers