Allow CTAS with temporary table in PXC strict mode

Bug #1666899 reported by Sander van Schie on 2017-02-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona XtraDB Cluster moved to https://jira.percona.com/projects/PXC
Fix Released
Undecided
Unassigned

Bug Description

In Percona XtraDB Cluster 5.7 when PXC Strict Mode is set to either ENFORCING or MASTER, CTAS statements are not allowed. This also applies to CTAS with temporary tables ("CREATE TEMPORARY TABLE ... AS SELECT").

According to the comments on https://www.percona.com/doc/percona-xtradb-cluster/5.7/features/pxc-strict-mode.html this isn't intended, asking to create a launchpad issue, so here it is.

Jericho Rivera (jericho-rivera) wrote :

mysql> select @@global.pxc_strict_mode;
+--------------------------+
| @@global.pxc_strict_mode |
+--------------------------+
| ENFORCING |
+--------------------------+
1 row in set (0.00 sec)

mysql> create temporary table t2 as select * from t1;
ERROR 1105 (HY000): Percona-XtraDB-Cluster prohibits use of CREATE TABLE AS SELECT with pxc_strict_mode = ENFORCING or MASTER

Error log:
2017-03-02T23:53:12.270010Z 14 [ERROR] WSREP: Percona-XtraDB-Cluster prohibits use of CREATE TABLE AS SELECT with pxc_strict_mode = ENFORCING or MASTER

Changed in percona-xtradb-cluster:
status: New → Confirmed
Changed in percona-xtradb-cluster:
status: Confirmed → Fix Committed
Changed in percona-xtradb-cluster:
status: Fix Committed → Fix Released

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXC-768

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers