5.6.25 mysql client depends on old readline

Bug #1506335 reported by Jervin R on 2015-10-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona XtraDB Cluster moved to https://jira.percona.com/projects/PXC
Status tracked in 5.6
5.5
Fix Released
Low
Tomislav Plavcic
5.6
Fix Released
Low
Tomislav Plavcic

Bug Description

mysql client from PXC: '5.6.25-73.1-25.12-log' wants readline-5 on CentOS 7. This is package from https://www.percona.com/downloads/Percona-XtraDB-Cluster-56/Percona-XtraDB-Cluster-5.6.25-25.12/binary/tarball/Percona-XtraDB-Cluster-5.6.25-rel73.1-25.12.1.Linux.x86_64.tar.gz

[revin@acme mysql]$ yum provides */libreadline.so.*
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.chi.host-engine.com
 * epel: mirror.us.leaseweb.net
 * extras: mirror.teklinks.com
 * updates: mirror.us.leaseweb.net
readline-6.2-9.el7.i686 : A library for editing typed command lines
Repo : base
Matched from:
Filename : /lib/libreadline.so.6.2
Filename : /lib/libreadline.so.6

readline-6.2-9.el7.x86_64 : A library for editing typed command lines
Repo : base
Matched from:
Filename : /lib64/libreadline.so.6.2
Filename : /lib64/libreadline.so.6

readline-6.2-9.el7.x86_64 : A library for editing typed command lines
Repo : @anaconda
Matched from:
Filename : /lib64/libreadline.so.6.2
Filename : /lib64/libreadline.so.6

[revin@acme mysql]$ /opt/mysql/5.6.253/bin/mysql --version
/opt/mysql/5.6.253/bin/mysql: error while loading shared libraries: libreadline.so.5: cannot open shared object file: No such file or directory
[revin@acme mysql]$

Tags: pkg Edit Tag help
Changed in percona-xtradb-cluster:
status: New → Triaged
assignee: nobody → Tomislav Plavcic (tplavcic)
tags: added: pkg
Tomislav Plavcic (tplavcic) wrote :

The issue exists because we started building with system readline and PXC binary tarballs are only built on centos5.
Percona Server binary tarball has builds on other distributions also (centos6 being one of them) because of libssl linkage so the issue isn't visible there.
It was agreed to start doing multiple binary tarballs builds for PXC as well so the issue will be fixed on the next release.

Changed in percona-xtradb-cluster:
milestone: none → future-5.6
Changed in percona-xtradb-cluster:
status: Triaged → Fix Committed

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXC-1155

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers