percona-xtradb-cluster init script is not honoring /etc/default/

Bug #1381492 reported by Mario Splivalo on 2014-10-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona XtraDB Cluster moved to https://jira.percona.com/projects/PXC
Status tracked in 5.6
5.5
Confirmed
Undecided
Unassigned
5.6
Fix Released
Undecided
Unassigned

Bug Description

Percona's init script is not honoring /etc/default in any way.

Using /etc/default (in this case I'm assuming /etc/default/mysql should be used) is a convenient way of setting up various environment options for the running services (it will also eliminate bug #1380747).

Tags: cts Edit Tag help
Ante Karamatić (ivoks) on 2014-10-15
tags: added: cts

@Mario,

Thanks. Yes, it should help.

I am assuming this request is for ubuntu/debian?

A similar thing was done for CentOS7 for systemd with EnvironmentFile for mysql@.service.

"
EnvironmentFile=/etc/sysconfig/mysql.%i
"

Similar thing can be done for ubuntu/debian as well.

Now, as per debian specifications, for debian, /etc/default seems to be the apt one.

Note, for CentOS7, mysql.service doesn't source any environment file. So, it will be added there as well.

Mario Splivalo (mariosplivalo) wrote :

@Raghavendra,

Yes, the request is originating for ubuntu/debian, but, as you've stated, RedHat/CentOS is affected as well.

@Mario,

Yes, all but mysql@.service in CentOS7 can do with this.

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXC-1754

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers