Relocatable RPMs

Bug #1247344 reported by Raghavendra D Prabhu on 2013-11-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MySQL Server
Unknown
Unknown
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.5
Triaged
Wishlist
Unassigned
5.6
Triaged
Wishlist
Unassigned
5.7
Triaged
Wishlist
Unassigned
Percona XtraBackup moved to https://jira.percona.com/projects/PXB
Triaged
Low
Unassigned
2.1
Triaged
Low
Unassigned
2.2
Triaged
Low
Unassigned
2.3
Triaged
Low
Unassigned
Percona XtraDB Cluster moved to https://jira.percona.com/projects/PXC
Status tracked in 5.6
5.5
Fix Released
Undecided
Alexey Bychko
5.6
Fix Released
Undecided
Raghavendra D Prabhu

Bug Description

Currently our RPMs cannot take a prefix for installation into a different root, this is because they are not relocatable. This bug is to track that.

tags: added: pkg

Adding PS and PXB for future ports.

This is what we have now:

[root@chief openxs]# rpm -i --relocate /usr=/tmp/usr percona-xtrabackup-2.1.6-702.rhel6.x86_64.rpm
        path /usr in package percona-xtrabackup-2.1.6-702.rhel6.x86_64 is not relocatable
[root@chief openxs]# rpm -i --prefix /tmp/usr percona-xtrabackup-2.1.6-702.rhel6.x86_64.rpm
error: package percona-xtrabackup is not relocatable

Changed in percona-xtrabackup:
status: New → Confirmed

Same with Percona Server RPMs:

[root@chief openxs]# rpm -i --prefix /tmp/usr Percona-Server-server-55-5.5.34-rel32.0.591.rhel6.x86_64.rpm
error: package Percona-Server-server-55 is not relocatable

tags: added: upstream
no longer affects: percona-server/5.1

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXC-1502

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXB-897

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-2437

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.