Percona XtraDB Cluster - HA scalable solution for MySQL

wsrep_sst_mysqldump fails with unbound variable warning

Reported by Alex Yurchenko on 2013-07-02
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MySQL patches by Codership
High
Alex Yurchenko
Percona XtraDB Cluster
Undecided
Raghavendra D Prabhu

Bug Description

/root/shm/mysql-5.5.31-3883,3143M/mysql//bin/wsrep_sst_common: line 89: WSREP_SST_OPT_DATA: unbound variable

This is a regression introduced by Percona (and mindlessly merged in by Codership) related to https://bugs.launchpad.net/codership-mysql/+bug/1193215

However it is not clear how to proceed from here, as progress indicator is a long awaited feature and mysqldump SST is not really dead yet.

WORKAROUNDS:
a) use another SST method
b) comment out line 89 if using mysqldump

Changed in codership-mysql:
assignee: nobody → Alex Yurchenko (ayurchen)
importance: Undecided → Medium
milestone: none → 5.5.32-23.7.6
status: New → Confirmed

Thanks, I will fix it. The sst progress was added only for rsync and xtrabackup SST methods.

Is WSREP_SST_OPT_DATA not set for mysqldump SST method?

Changed in percona-xtradb-cluster:
milestone: none → 5.5.32-24
Changed in percona-xtradb-cluster:
status: New → Fix Committed
assignee: nobody → Raghavendra D Prabhu (raghavendra-prabhu)

Fixed with

[ -n $WSREP_SST_OPT_DATA ] && SST_PROGRESS_FILE="$WSREP_SST_OPT_DATA/sst_in_progress"

However, progress indicator in lp:1193215 is not same as
lp:1193215, former is only applicable for blocking init scripts
till SST is complete, latter is meant to indicate SST progress.

Alex Yurchenko (ayurchen) wrote :

Well, mysqldump is not totally dead yet, and probably would benefit from progress indication as well. But in order to make it rsync/xtrabackup compatible we'll need to pass datadir to it. That would require a small change in wsrep_sst.cc.

Ack, I intended to add this progress file for mysqldump too but it was a bit different there, hence didn't add. I will add it in a separate issue.

"However, progress indicator in lp:1193215 is not same as
lp:1193215, former is only applicable for blocking init scripts
till SST is complete, latter is meant to indicate SST progress."

should be

"However, progress indicator in lp:1099428 is not same as
lp:1193215, former is only applicable for blocking init scripts
till SST is complete, latter is meant to indicate SST progress."

Seppo Jaakola (seppo-jaakola) wrote :

Merged the PXC fix into codership-mysql, in revision: http://bazaar.launchpad.net/~codership/codership-mysql/5.5-23/revision/3895

Changed in codership-mysql:
status: Confirmed → Fix Committed
assignee: Alex Yurchenko (ayurchen) → Seppo Jaakola (seppo-jaakola)

I'm seeing the same problem with wsrep_sst_xtrabackup

/usr/bin/wsrep_sst_xtrabackup
/usr/bin/wsrep_sst_common: line 89: WSREP_SST_OPT_DATA: unbound variable

I retract my previous comment. I only now realized that the problem is was in wsrep_sst_common. Obviously the fix would apply to the other scripts that depend on it.

@Marc,

You shouldn't have received this error while using wsrep_sst_xtrabackup since datadir is passed to the script. If you did, then it is either a bug elsewhere or in option handling. (or with handling of innodb_data_home_dir etc.)

Alex Yurchenko (ayurchen) wrote :

Reopening, since I'm getting this

/run/shm/galera1/mysql//bin/wsrep_sst_mysqldump: 89: /run/shm/galera1/mysql//bin/wsrep_sst_common: WSREP_SST_OPT_DATA: parameter not set

- at least with dash. Also, SST_PROGRESS_FILE cleanup is buggy this way

Changed in codership-mysql:
assignee: Seppo Jaakola (seppo-jaakola) → Alex Yurchenko (ayurchen)
importance: Medium → High
status: Fix Committed → In Progress
Alex Yurchenko (ayurchen) wrote :
Changed in codership-mysql:
status: In Progress → Fix Committed
Changed in codership-mysql:
status: Fix Committed → Fix Released
Changed in percona-xtradb-cluster:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers