Percona XtraDB Cluster - HA scalable solution for MySQL

Failing assertion: mutex_own(mutex) in pfs_mutex_exit_func | debug build only

Reported by Raghavendra D Prabhu on 2013-06-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona XtraDB Cluster
Undecided
Raghavendra D Prabhu

Bug Description

Saw following crash during a RQG run:

130617 11:15:26 InnoDB: Assertion failure in thread 140548578158336 in file sync0sync.ic line 163
InnoDB: Failing assertion: mutex_own(mutex)
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
05:45:26 UTC - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed,
something is definitely wrong and this may fail.
Please help us make Percona Server better by reporting any
bugs at http://bugs.percona.com/

key_buffer_size=67108864
read_buffer_size=131072
max_used_connections=9
max_threads=10002
thread_count=4
connection_count=4
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 21956775 K bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x2bf24f0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 7fd404131e68 thread_stack 0x40000
/pxc/bin/mysqld(my_print_stacktrace+0x2c)[0x80daba]
/pxc/bin/mysqld(handle_fatal_signal+0x30f)[0x6cdbbb]
/usr/lib/libpthread.so.0(+0xf0e0)[0x7fd4214f40e0]
/usr/lib/libc.so.6(gsignal+0x39)[0x7fd41fca31c9]
/usr/lib/libc.so.6(abort+0x148)[0x7fd41fca45c8]
/pxc/bin/mysqld[0x90860d]
/pxc/bin/mysqld[0x910983]
/pxc/bin/mysqld[0x8f4e49]
/pxc/bin/mysqld[0xa03f91]
/pxc/bin/mysqld[0xa07ee1]
/pxc/bin/mysqld[0xa08ae1]
/pxc/bin/mysqld[0x862248]
/pxc/bin/mysqld[0x83412a]
/pxc/bin/mysqld(_ZN7handler12ha_write_rowEPh+0xa0)[0x6d702a]
/pxc/bin/mysqld(_Z12write_recordP3THDP5TABLEP12st_copy_info+0x6a2)[0x5856e8]
/pxc/bin/mysqld(_Z12mysql_insertP3THDP10TABLE_LISTR4ListI4ItemERS3_IS5_ES6_S6_15enum_duplicatesb+0x1fb5)[0x5890cf]
/pxc/bin/mysqld(_Z21mysql_execute_commandP3THD+0x32b7)[0x59ec5f]
/pxc/bin/mysqld(_Z11mysql_parseP3THDPcjP12Parser_state+0x20a)[0x5a45a1]
/pxc/bin/mysqld[0x5a5213]
/pxc/bin/mysqld(_Z16dispatch_command19enum_server_commandP3THDPcj+0xa62)[0x5a61e9]
/pxc/bin/mysqld(_Z10do_commandP3THD+0x6c0)[0x5a7f0a]
/pxc/bin/mysqld(_Z24do_handle_one_connectionP3THD+0x143)[0x654a7a]
/pxc/bin/mysqld(handle_one_connection+0x49)[0x654cae]
/usr/lib/libpthread.so.0(+0x7dd2)[0x7fd4214ecdd2]
/usr/lib/libc.so.6(clone+0x6d)[0x7fd41fd53cdd]

Trying to get some variables.
Some pointers may be invalid and cause the dump to abort.
Query (7fd3b42c24f0): is an invalid pointer
Connection ID (thread ID): 22
Status: NOT_KILLED

==================================================================================================

>>resolve_stack_dump -s /tmp/mysqld.sym -n /tmp/syms | c++filt
0x80daba my_print_stacktrace + 44
0x6cdbbb handle_fatal_signal + 783
0x7fd4214f40e0 _end + 540200472
0x7fd41fca31c9 _end + 514703105
0x7fd41fca45c8 _end + 514708224
0x90860d pfs_mutex_exit_func + 87
0x910983 buf_page_get_gen + 3374
0x8f4e49 btr_store_big_rec_extern_fields + 2260
0xa03f91 row_ins_index_entry_low + 7611
0xa07ee1 row_ins_index_entry + 1288
0xa08ae1 row_ins_step + 2860
0x862248 row_insert_for_mysql + 992
0x83412a ha_innobase::write_row(unsigned char*) + 1264
0x6d702a handler::ha_write_row(unsigned char*) + 160
0x5856e8 write_record(THD*, TABLE*, st_copy_info*) + 1698
0x5890cf mysql_insert(THD*, TABLE_LIST*, List<Item>&, List<List<Item> >&, List<Item>&, List<Item>&, enum_duplicates, bool) + 8117
0x59ec5f mysql_execute_command(THD*) + 12983
0x5a45a1 mysql_parse(THD*, char*, unsigned int, Parser_state*) + 522
0x5a5213 wsrep_mysql_parse(THD*, char*, unsigned int, Parser_state*) + 278
0x5a61e9 dispatch_command(enum_server_command, THD*, char*, unsigned int) + 2658
0x5a7f0a do_command(THD*) + 1728
0x654a7a do_handle_one_connection(THD*) + 323

=================================================================================

It was due to a merge regression.

Changed in percona-xtradb-cluster:
milestone: none → 5.5.31-23.7.5
status: New → Fix Released
assignee: nobody → Raghavendra D Prabhu (raghavendra-prabhu)
summary: - Crash with debug build
+ Failing assertion: mutex_own(mutex) in pfs_mutex_exit_func | debug build
+ only
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers