Percona XtraDB Cluster - HA scalable solution for MySQL

Percona-Server-shared-55 does not provide /usr/lib64/libmysqlclient_r* however the rpm does list them as files.

Reported by David Busby on 2013-04-23
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Percona Server
Status tracked in 5.6
5.5
High
Unassigned
5.6
High
Unassigned
Percona XtraDB Cluster
High
Unassigned

Bug Description

An odd issue was noted today:

Percona-Server-server-55

[root@localhost lib64]# rpm -qa | grep Percona
rpm -qa | grep Percona
Percona-Server-client-55-5.5.30-rel30.2.508.rhel6.x86_64
Percona-Server-server-55-5.5.30-rel30.2.508.rhel6.x86_64
Percona-Server-shared-55-5.5.30-rel30.2.508.rhel6.x86_64
[root@localhost lib64]# rpm -ql Percona-Server-shared-55
rpm -ql Percona-Server-shared-55
/usr/lib64/libmysqlclient.so.18
/usr/lib64/libmysqlclient.so.18.0.0
/usr/lib64/libmysqlclient_r.so.18
/usr/lib64/libmysqlclient_r.so.18.0.0
/usr/lib64/mysql/plugin/libfnv1a_udf.a
/usr/lib64/mysql/plugin/libfnv1a_udf.la
/usr/lib64/mysql/plugin/libfnv_udf.a
/usr/lib64/mysql/plugin/libfnv_udf.la
/usr/lib64/mysql/plugin/libmurmur_udf.a
/usr/lib64/mysql/plugin/libmurmur_udf.la

[root@localhost lib64]# ls -al /usr/lib64/libmysqlclient_r*
ls -al /usr/lib64/libmysqlclient_r*
ls: cannot access /usr/lib64/libmysqlclient_r*: No such file or directory

[root@localhost lib64]# ls -al /usr/lib64/libmysqlclient*
ls -al /usr/lib64/libmysqlclient*
lrwxrwxrwx. 1 root root 24 Apr 23 09:12 /usr/lib64/libmysqlclient.so.18 -> libmysqlclient.so.18.0.0
-rwxr-xr-x. 1 root root 3153920 Apr 19 19:40 /usr/lib64/libmysqlclient.so.18.0.0
[root@localhost lib64]

post installation of Percona-Server-shared-compat:

---
[root@localhost lib64]# ls -al /usr/lib64/libmysqlclient*^[[3~
ls -al /usr/lib64/libmysqlclient*
lrwxrwxrwx. 1 root root 26 Apr 23 09:51 /usr/lib64/libmysqlclient_r.so.12 -> libmysqlclient_r.so.12.0.0
-rwxr-xr-x. 1 root root 262312 Apr 19 20:13 /usr/lib64/libmysqlclient_r.so.12.0.0
lrwxrwxrwx. 1 root root 26 Apr 23 09:51 /usr/lib64/libmysqlclient_r.so.14 -> libmysqlclient_r.so.14.0.0
-rwxr-xr-x. 1 root root 1354304 Apr 19 20:13 /usr/lib64/libmysqlclient_r.so.14.0.0
lrwxrwxrwx. 1 root root 26 Apr 23 09:51 /usr/lib64/libmysqlclient_r.so.15 -> libmysqlclient_r.so.15.0.0
-rwxr-xr-x. 1 root root 2070320 Apr 19 20:13 /usr/lib64/libmysqlclient_r.so.15.0.0
lrwxrwxrwx. 1 root root 26 Apr 23 09:51 /usr/lib64/libmysqlclient_r.so.16 -> libmysqlclient_r.so.16.0.0
-rwxr-xr-x. 1 root root 1498144 Apr 19 20:13 /usr/lib64/libmysqlclient_r.so.16.0.0
lrwxrwxrwx. 1 root root 24 Apr 23 09:51 /usr/lib64/libmysqlclient.so.12 -> libmysqlclient.so.12.0.0
-rwxr-xr-x. 1 root root 253888 Apr 19 20:13 /usr/lib64/libmysqlclient.so.12.0.0
lrwxrwxrwx. 1 root root 24 Apr 23 09:51 /usr/lib64/libmysqlclient.so.14 -> libmysqlclient.so.14.0.0
-rwxr-xr-x. 1 root root 1345984 Apr 19 20:13 /usr/lib64/libmysqlclient.so.14.0.0
lrwxrwxrwx. 1 root root 24 Apr 23 09:51 /usr/lib64/libmysqlclient.so.15 -> libmysqlclient.so.15.0.0
-rwxr-xr-x. 1 root root 2059336 Apr 19 20:13 /usr/lib64/libmysqlclient.so.15.0.0
lrwxrwxrwx. 1 root root 24 Apr 23 09:51 /usr/lib64/libmysqlclient.so.16 -> libmysqlclient.so.16.0.0
-rwxr-xr-x. 1 root root 1487576 Apr 19 20:13 /usr/lib64/libmysqlclient.so.16.0.0
lrwxrwxrwx. 1 root root 24 Apr 23 09:12 /usr/lib64/libmysqlclient.so.18 -> libmysqlclient.so.18.0.0
-rwxr-xr-x. 1 root root 3153920 Apr 19 19:40 /usr/lib64/libmysqlclient.so.18.0.0
---

(note issue with .16 libs here: https://bugs.launchpad.net/percona-server/+bug/1171755)

_r.so.18 appears to be missing entirely.

tags: added: pkg
Changed in percona-server:
assignee: nobody → Ignacio Nin (ignacio-nin)
importance: Undecided → High
status: New → Confirmed
Ignacio Nin (ignacio-nin) wrote :

Confirmed. After install of Percona-Server-shared-55 5.5.30-rel30.2.508.rhel6:

[root@centos6 ~]# rpm -ql Percona-Server-shared-55
/usr/lib64/libmysqlclient.so.18
/usr/lib64/libmysqlclient.so.18.0.0
/usr/lib64/libmysqlclient_r.so.18
/usr/lib64/libmysqlclient_r.so.18.0.0
/usr/lib64/mysql/plugin/libfnv1a_udf.a
/usr/lib64/mysql/plugin/libfnv1a_udf.la
/usr/lib64/mysql/plugin/libfnv_udf.a
/usr/lib64/mysql/plugin/libfnv_udf.la
/usr/lib64/mysql/plugin/libmurmur_udf.a
/usr/lib64/mysql/plugin/libmurmur_udf.la
[root@centos6 ~]# rpm -qV Percona-Server-shared-55
missing /usr/lib64/libmysqlclient_r.so.18
missing /usr/lib64/libmysqlclient_r.so.18.0.0

This issue was also present in 5.5.30-30.1, but not in 5.5.30-30.0

Ignacio Nin (ignacio-nin) wrote :

This regression was introduced in revno 470. The symbolic links libmysqlclient_r.so.18 and libmysqlclient_r.so.18.0.0 point to libmysqlclient.so instead of pointing to the versioned library libmysqlclient.so.18.

Since at this revision libmysqlclient.so was moved to the Percona-Server-devel-55 package, the symlinks point nowhere and are not installed. The fix is to have them point to the versioned library, contained in the shared package.

Percona XtraDB Cluster 5.5.30 is also affected by this issue. Percona Server 5.6 is not since CMake installs correctly the files (pointing to the versioned library).

no longer affects: percona-server
Changed in percona-xtradb-cluster:
status: New → Confirmed
importance: Undecided → Critical
importance: Critical → High
assignee: nobody → Ignacio Nin (ignacio-nin)
milestone: none → 5.5.30-24.8
Changed in percona-server:
status: New → Confirmed
importance: Undecided → High
status: Confirmed → Invalid
Changed in percona-xtradb-cluster:
status: Confirmed → In Progress
Ignacio Nin (ignacio-nin) wrote :

5.6 could be affected in some way after 470 gets merged on it, adding for future tracking

Changed in percona-xtradb-cluster:
status: In Progress → Fix Committed
tags: added: rdba
Changed in percona-xtradb-cluster:
milestone: 5.5.31-23.7.5 → 5.5.31-25
Changed in percona-xtradb-cluster:
status: Fix Committed → Fix Released
Stewart Smith (stewart) on 2013-11-13
Changed in percona-xtradb-cluster:
assignee: Ignacio Nin (ignacio-nin) → nobody
Andrian Jardan (andrianjardan) wrote :

This is again present in Percona-Server-shared-55, the last version containing /usr/lib64/libmysqlclient.so.18 is

Percona-Server-shared-55.x86_64 0:5.5.35-rel33.0.611

Tested on latest CentOS5 64 bit

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers