Percona XtraDB Cluster - HA scalable solution for MySQL

CTAS conflict with DDL can cause node hanging

Reported by Seppo Jaakola on 2013-04-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MySQL patches by Codership
Medium
Seppo Jaakola
Percona XtraDB Cluster
Status tracked in Trunk
5.6
Undecided
Unassigned
Trunk
Undecided
Unassigned

Bug Description

if create table as select runs in parallel with DDL statement operating on the select table, it can happen that CTAS processing remains hanging.

The problem relates to rollback of the CTAS, which involves rolling back both the transaction (of insert statements) and create table. It turns out that the table is not always dropped during this rollback and this causes issues later on.

The problem was first observed by RQG percona_qa run against one PXC node, but it is also possible to reproduce by two clients, where one runs: "CREATE TABLE t1 AS SELECT * FROM t2" and the other runs: "TRUNCATE t2;

Changed in codership-mysql:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Seppo Jaakola (seppo-jaakola)
milestone: none → 5.5.30-23.7.4
Seppo Jaakola (seppo-jaakola) wrote :

Fix pushed in http://bazaar.launchpad.net/~codership/codership-mysql/5.5-23/revision/3861
The CTAS - TRUNCATE test passes with this fix.

Changed in codership-mysql:
status: In Progress → Fix Committed
Changed in percona-xtradb-cluster:
milestone: none → 5.5.30-24.8
milestone: 5.5.30-24.8 → 5.5.30-23.7.4
Changed in percona-xtradb-cluster:
status: New → Fix Released
Changed in codership-mysql:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers