Percona XtraDB Cluster - HA scalable solution for MySQL

message relay requesting goes on/off with multicast

Reported by Teemu Ollakka on 2013-04-02
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Galera
Undecided
Teemu Ollakka
Percona XtraDB Cluster
Status tracked in Trunk
5.6
Undecided
Unassigned
Trunk
Undecided
Unassigned

Bug Description

If gcomm is configured with multicast, lots of "turning message relay requesting off"/"turning message relay requesting on" messages will appear in log. This is caused by lack of messages going through gmcast level TCP sockets, making gmcast peer liveness checking to fail constantly (false positives).

Workaround: Configure "gmcast.peer_timeout=PT1Y" to effectively disable liveness cheking for TCP sockets.

Changed in galera:
milestone: none → 3.0beta
status: New → Confirmed
assignee: nobody → Teemu Ollakka (teemu-ollakka)
Changed in galera:
milestone: 3.0beta → 3.0
Changed in galera:
status: Confirmed → Fix Committed
Changed in galera:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers