Percona XtraDB Cluster - HA scalable solution for MySQL

Prepared statements can cause node hanging

Reported by Seppo Jaakola on 2013-03-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MySQL patches by Codership
Medium
Seppo Jaakola
Percona XtraDB Cluster
Undecided
Unassigned

Bug Description

Conflicting prepared statements in multi-master use case can cause node to hang. The symptom is different in Percona XtraDB Cluster and Galera Cluster, but the underlying issue deals with prepared statement execution loop, which does not honor wsrep status codes correctly.

A good way to reproduce, is to run sysbench version 0.4 oltp mode, with high conflict rate and load balanced against two nodes, e.g. like here:

sysbench --test=oltp --oltp-auto-inc=off --oltp-test-mode=nontrx --oltp-nontrx-mode=update_key --oltp-table-size=1000 --num-threads=32 --init-rng=on --max-requests=0 --max-time=3000 run

Changed in codership-mysql:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Seppo Jaakola (seppo-jaakola)
milestone: none → 5.5.29-23.7.3
Seppo Jaakola (seppo-jaakola) wrote :

PXC suffers from unresolved BF conflict, due to the victim being in sticky CERT_FAILURE state.
GC suffers from unhandled replaying states, replaying was never started.

Both issues have a fix in revision: http://bazaar.launchpad.net/~codership/codership-mysql/5.5-23/revision/3853

Changed in codership-mysql:
status: In Progress → Fix Committed
Changed in codership-mysql:
status: Fix Committed → Fix Released
Changed in percona-xtradb-cluster:
milestone: none → 5.5.30-23.7.4
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers