Percona XtraDB Cluster - HA scalable solution for MySQL

RPM Rebuild of Percona XtraDB Cluster 5.5.28 Fails

Reported by Jervin R on 2012-12-06
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Percona Server
High
Ignacio Nin
5.5
High
Ignacio Nin
Percona XtraDB Cluster
High
Ignacio Nin
Percona-xtradb-cluster-5.5
High
Ignacio Nin

Bug Description

http://www.percona.com/redir/downloads/Percona-XtraDB-Cluster/LATEST/source/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.src.rpm

[root@percona SPECS]# cat /etc/redhat-release
CentOS release 6.3 (Final)
[root@percona SPECS]# uname -a
Linux percona.localdomain 2.6.32-279.2.1.el6.x86_64 #1 SMP Fri Jul 20 01:55:29 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
[root@percona SPECS]#

With the following error:

Processing files: Percona-XtraDB-Cluster-server-5.5.28-%{wsrep_version}.1.rhel6.x86_64
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/daemon_example.ini
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/adt_null.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/libdaemon_example.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/mypluglib.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/semisync_master.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/semisync_slave.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/auth.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/auth_socket.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/auth_test_plugin.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/qa_auth_client.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/qa_auth_interface.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/qa_auth_server.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/auth_pam.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/auth_pam_compat.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/dialog.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/debug/adt_null.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/debug/libdaemon_example.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/debug/mypluglib.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/debug/semisync_master.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/debug/semisync_slave.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/debug/auth.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/debug/auth_socket.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/debug/auth_test_plugin.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/debug/qa_auth_client.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/debug/qa_auth_interface.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/debug/qa_auth_server.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/debug/auth_pam.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/debug/auth_pam_compat.so
error: File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-%{wsrep_version}.1.rhel6.x86_64/usr/lib64/mysql/plugin/debug/dialog.so
Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.4sLMxq

Tags: pkg Edit Tag help
Changed in percona-xtradb-cluster:
status: New → Confirmed
assignee: nobody → Ignacio Nin (ignacio-nin)
tags: added: pkg
Roel Van de Paar (roel11) wrote :

Same bug in both PS and PXC. Likely universal fix which applies to both.

Bug 1088865 was made a duplicate of this bug
Bug 1099809 was made a duplicate of bug 1088865 and is therefore also a duplicate of this one

Changed in percona-xtradb-cluster:
importance: Undecided → High
Alexey Bychko (abychko) wrote :

raised priority
<laurynas> its binaries were supposed to be built and packaged with Percona Server binaries
<laurynas> if that's not happening, then it's a critical bug for the PAM plugin

Changed in percona-xtradb-cluster:
importance: High → Critical

Resetting triage back to "High", sorry for the misunderstanding re. "critical."

Changed in percona-xtradb-cluster:
importance: Critical → High
status: Confirmed → Triaged

Note, lp:1099809 only mentions the PAM plugin, but the error in related bugs has included other plugins as well.

Roel Van de Paar (roel11) wrote :

Bug 1095575 was made a duplicate of this bug

Seems like an often seen issue. Maybe 'critical' applies to this bug after all?

Roel Van de Paar (roel11) wrote :

Status:

-Merge proposal for PS side ready by AlexeyB @ https://code.launchpad.net/~abychko/percona-server/bug1099809/+merge/143636
-PXC side: to be done (Ignacio looking into this)

Alexey Bychko (abychko) wrote :
Download full text (3.9 KiB)

confirmed build error with Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.src.rpm

File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/daemon_example.ini
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/adt_null.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/libdaemon_example.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/mypluglib.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/semisync_master.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/semisync_slave.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/auth.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/auth_socket.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/auth_test_plugin.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/qa_auth_client.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/qa_auth_interface.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/qa_auth_server.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/auth_pam.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/auth_pam_compat.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/dialog.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/debug/adt_null.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/debug/libdaemon_example.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/debug/mypluglib.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/debug/semisync_master.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/debug/semisync_slave.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/debug/auth.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/debug/auth_socket.so
File not found: /root/rpmbuild/BUILDROOT/Percona-XtraDB-Cluster-5.5.28-23.7.369.rhel6.x86_64/usr/lib64/mysql/plugin/debug/auth_test_plugin.so
File not found: /root/rpmbuild/BUI...

Read more...

Alexey Bychko (abychko) wrote :

can't reproduce on latest bzr source r383

Changed in percona-xtradb-cluster:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers