Dependency Conflict between Percona-XtraDB-Cluster-shared and Percona-Server-shared-compat

Bug #1084309 reported by Nathan West on 2012-11-29
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Percona XtraDB Cluster moved to https://jira.percona.com/projects/PXC
Status tracked in 5.6
5.5
Fix Released
Undecided
Ignacio Nin
5.6
Fix Released
Undecided
Raghavendra D Prabhu

Bug Description

Hello,

I've installed Percona-XtraDB-Cluster-5.5.28 on CentOS 6.3 and have it up and running successfully. (using yum)

I've attempted to install the percona-toolkit but have had issues resolving some dependencies. I was able to resolve all of them except for perl(DBD::mysql) Log is below.

No other mysql version had been installed previously.

I tried to softlink libmysqlclient.so.16, following a forum post I found but that didn't work. I also tried to install the Percona-server-shared-compat library, but that erred with other dependency issues.

[root@percona1 ~]# yum install percona-toolkit
Loaded plugins: fastestmirror, presto
Loading mirror speeds from cached hostfile
 * base: dist1.800hosting.com
 * epel: mirror.steadfast.net
 * extras: centos.mirrors.tds.net
 * updates: mirror.cisp.com
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package percona-toolkit.noarch 0:2.1.7-1 will be installed
--> Processing Dependency: perl(DBD::mysql) >= 1.0 for package: percona-toolkit-2.1.7-1.noarch
--> Running transaction check
---> Package perl-DBD-MySQL.x86_64 0:4.013-3.el6 will be installed
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: perl-DBD-MySQL-4.013-3.el6.x86_64
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: perl-DBD-MySQL-4.013-3.el6.x86_64
--> Running transaction check
---> Package Percona-Server-shared-51.x86_64 0:5.1.66-rel14.1.496.rhel6 will be installed
--> Processing Conflict: 1:Percona-XtraDB-Cluster-shared-5.5.28-23.7.369.rhel6.x86_64 conflicts Percona-Server-shared-51
--> Processing Conflict: 1:Percona-XtraDB-Cluster-shared-5.5.28-23.7.369.rhel6.x86_64 conflicts mysql-libs
--> Finished Dependency Resolution
Error: Percona-XtraDB-Cluster-shared conflicts with Percona-Server-shared-51
 You could try using --skip-broken to work around the problem
** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
1:Percona-XtraDB-Cluster-client-5.5.28-23.7.369.rhel6.x86_64 has installed conflicts mysql: 1:Percona-XtraDB-Cluster-client-5.5.28-23.7.369.rhel6.x86_64
1:Percona-XtraDB-Cluster-server-5.5.28-23.7.369.rhel6.x86_64 has installed conflicts mysql-server: 1:Percona-XtraDB-Cluster-server-5.5.28-23.7.369.rhel6.x86_64
1:Percona-XtraDB-Cluster-shared-5.5.28-23.7.369.rhel6.x86_64 has installed conflicts mysql-libs: 1:Percona-XtraDB-Cluster-shared-5.5.28-23.7.369.rhel6.x86_64

Related branches

@Nathan,

This is a known issue, for now, the workaround is to install
Percona-Server-shared-compat before installing the
percona-toolkit. Let us know if this fixes your issue.

affects: percona-server → percona-xtradb-cluster
Nathan West (nathan-west) wrote :

@Raghavendra

Thanks for the quick response. Installing the shared-compat library failed also.

Do I need to install the shared-compat library before XtraDB-cluster?

[root@percona1 yum.repos.d]# yum install Percona-Server-shared-compat
Loaded plugins: fastestmirror, presto
Loading mirror speeds from cached hostfile
epel/metalink | 11 kB 00:00
 * base: dist1.800hosting.com
 * epel: mirror.unl.edu
 * extras: centos.mirrors.tds.net
 * updates: mirror.cisp.com
base | 3.7 kB 00:00
epel | 4.3 kB 00:00
epel/primary_db | 4.9 MB 00:01
extras | 3.5 kB 00:00
percona | 951 B 00:00
rbel6 | 1.9 kB 00:00
updates | 3.5 kB 00:00
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package Percona-Server-shared-compat.x86_64 0:5.5.28-rel29.1.335.rhel6 will be installed
--> Processing Conflict: 1:Percona-XtraDB-Cluster-shared-5.5.28-23.7.369.rhel6.x86_64 conflicts mysql-libs
--> Finished Dependency Resolution
Error: Percona-XtraDB-Cluster-shared conflicts with Percona-Server-shared-compat
 You could try using --skip-broken to work around the problem
** Found 3 pre-existing rpmdb problem(s), 'yum check' output follows:
1:Percona-XtraDB-Cluster-client-5.5.28-23.7.369.rhel6.x86_64 has installed conflicts mysql: 1:Percona-XtraDB-Cluster-client-5.5.28-23.7.369.rhel6.x86_64
1:Percona-XtraDB-Cluster-server-5.5.28-23.7.369.rhel6.x86_64 has installed conflicts mysql-server: 1:Percona-XtraDB-Cluster-server-5.5.28-23.7.369.rhel6.x86_64
1:Percona-XtraDB-Cluster-shared-5.5.28-23.7.369.rhel6.x86_64 has installed conflicts mysql-libs: 1:Percona-XtraDB-Cluster-shared-5.5.28-23.7.369.rhel6.x86_64

@Nathan,

It is broken with 5.5.28 PXC, though not broken with 5.5.27.
Looks like a regression. Thanks for the details.

This is because:

sudo repoquery --conflicts Percona-XtraDB-Cluster-shared
Percona-Server-shared-51
Percona-Server-shared-55
mysql-libs
raghu archie:~ [118]% sudo repoquery --provides Percona-Server-shared-compat
MySQL-shared
Percona-Server-shared-compat = 5.5.28-rel29.1.335.rhel6
Percona-Server-shared-compat(x86-64) = 5.5.28-rel29.1.335.rhel6
libmysqlclient.so.12()(64bit)
libmysqlclient.so.14()(64bit)
libmysqlclient.so.14(libmysqlclient_14)(64bit)
libmysqlclient.so.15()(64bit)
libmysqlclient.so.15(libmysqlclient_15)(64bit)
libmysqlclient.so.16()(64bit)
libmysqlclient.so.16(libmysqlclient_16)(64bit)
libmysqlclient_r.so.12()(64bit)
libmysqlclient_r.so.14()(64bit)
libmysqlclient_r.so.14(libmysqlclient_14)(64bit)
libmysqlclient_r.so.15()(64bit)
libmysqlclient_r.so.15(libmysqlclient_15)(64bit)
libmysqlclient_r.so.16()(64bit)
libmysqlclient_r.so.16(libmysqlclient_16)(64bit)
mysql-libs

Changed in percona-xtradb-cluster:
status: New → Confirmed
assignee: nobody → Ignacio Nin (ignacio-nin)

For 5.5.27:

sudo rpm -q --conflicts Percona-XtraDB-Cluster-shared
Percona-Server-shared-55
Percona-Server-shared-51

For 5.5.28:

sudo repoquery --conflicts Percona-XtraDB-Cluster-shared
Percona-Server-shared-51
Percona-Server-shared-55
mysql-libs

mysql-libs was added and is causing the conflict.

summary: - Dependency Conflict between Xtra-DB-Cluster and percona-toolkit
+ Dependency Conflict between Percona-XtraDB-Cluster-shared and Percona-
+ Server-shared-compat
tags: added: regression
tags: added: pkg

@Nathan,

I don't see mysql-libs in Conflicts: any longer. Are you still
seeing this issue?

Changed in percona-xtradb-cluster:
status: Confirmed → New

Marking as incomplete for now.

Changed in percona-xtradb-cluster:
status: New → Incomplete
Lars Wilke (lw-lwilke) wrote :

Hi,

i see this problem.

On a complete new CentOS6.4 install i do the following:

1. rpm -Uhv http://www.percona.com/downloads/percona-release/percona-release-0.0-2.x86_64.rpm
2. rpm -qa|grep -i percona
    => percona-release-0.0-1.x86_64
3. yum upgrade, and i get

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.mirror.linuxwerk.com
 * epel: vesta.informatik.rwth-aachen.de
 * extras: centos.mirror.linuxwerk.com
 * updates: ftp.hosteurope.de
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package Percona-Server-shared-51.x86_64 0:5.1.70-rel14.8.580.rhel6 will be obsoleting
---> Package Percona-Server-shared-55.x86_64 0:5.5.32-rel31.0.549.rhel6 will be obsoleting
---> Package Percona-Server-shared-56.x86_64 0:5.6.12-rc60.4.393.rhel6 will be obsoleting
---> Package Percona-Server-shared-compat.x86_64 0:5.5.32-rel31.0.549.rhel6 will be obsoleting
---> Package Percona-XtraDB-Cluster-shared.x86_64 1:5.5.31-23.7.5.438.rhel6 will be obsoleting
---> Package mysql-libs.x86_64 0:5.1.69-1.el6_4 will be obsoleted
--> Processing Conflict: Percona-Server-shared-56-5.6.12-rc60.4.393.rhel6.x86_64 conflicts Percona-Server-shared-55
--> Processing Conflict: 1:Percona-XtraDB-Cluster-shared-5.5.31-23.7.5.438.rhel6.x86_64 conflicts Percona-Server-shared-55
--> Finished Dependency Resolution
Error: Percona-XtraDB-Cluster-shared conflicts with Percona-Server-shared-55-5.5.32-rel31.0.549.rhel6.x86_64
Error: Percona-Server-shared-56 conflicts with Percona-Server-shared-55-5.5.32-rel31.0.549.rhel6.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

The mysql-libs are a postfix dependency. See rpm -qR postfix.

Lars Wilke (lw-lwilke) wrote :

yum -x "Percona-Server-shared-*" upgrade
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.mirror.linuxwerk.com
 * epel: vesta.informatik.rwth-aachen.de
 * extras: centos.mirror.linuxwerk.com
 * updates: ftp.hosteurope.de
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package Percona-XtraDB-Cluster-shared.x86_64 1:5.5.31-23.7.5.438.rhel6 will be obsoleting
---> Package mysql-libs.x86_64 0:5.1.69-1.el6_4 will be obsoleted
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: 2:postfix-2.6.6-2.2.el6_1.x86_64
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: 2:postfix-2.6.6-2.2.el6_1.x86_64
--> Finished Dependency Resolution
Error: Package: 2:postfix-2.6.6-2.2.el6_1.x86_64 (@base)
           Requires: libmysqlclient.so.16()(64bit)
           Removing: mysql-libs-5.1.69-1.el6_4.x86_64 (@updates)
               libmysqlclient.so.16()(64bit)
           Obsoleted By: 1:Percona-XtraDB-Cluster-shared-5.5.31-23.7.5.438.rhel6.x86_64 (percona)
               Not found
           Available: mysql-libs-5.1.66-2.el6_3.x86_64 (base)
               libmysqlclient.so.16()(64bit)
           Available: mysql-libs-5.1.67-1.el6_3.x86_64 (updates)
               libmysqlclient.so.16()(64bit)
Error: Package: 2:postfix-2.6.6-2.2.el6_1.x86_64 (@base)
           Requires: libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Removing: mysql-libs-5.1.69-1.el6_4.x86_64 (@updates)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Obsoleted By: 1:Percona-XtraDB-Cluster-shared-5.5.31-23.7.5.438.rhel6.x86_64 (percona)
               Not found
           Available: mysql-libs-5.1.66-2.el6_3.x86_64 (base)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
           Available: mysql-libs-5.1.67-1.el6_3.x86_64 (updates)
               libmysqlclient.so.16(libmysqlclient_16)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Lars Wilke (lw-lwilke) wrote :

A possible solution

yum install Percona-XtraDB-Cluster-shared
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.mirror.linuxwerk.com
 * epel: vesta.informatik.rwth-aachen.de
 * extras: centos.mirror.linuxwerk.com
 * updates: ftp.hosteurope.de
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package Percona-XtraDB-Cluster-shared.x86_64 1:5.5.31-23.7.5.438.rhel6 will be obsoleting
---> Package mysql-libs.x86_64 0:5.1.69-1.el6_4 will be obsoleted
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: 2:postfix-2.6.6-2.2.el6_1.x86_64
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: 2:postfix-2.6.6-2.2.el6_1.x86_64
--> Running transaction check
---> Package Percona-Server-shared-compat.x86_64 0:5.5.32-rel31.0.549.rhel6 will be obsoleting
--> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================================================
 Package Arch Version Repository Size
=========================================================================================================================================
Installing:
 Percona-Server-shared-compat x86_64 5.5.32-rel31.0.549.rhel6 percona 3.4 M
     replacing mysql-libs.x86_64 5.1.69-1.el6_4
 Percona-XtraDB-Cluster-shared x86_64 1:5.5.31-23.7.5.438.rhel6 percona 648 k
     replacing mysql-libs.x86_64 5.1.69-1.el6_4

Transaction Summary
=========================================================================================================================================
Install 2 Package(s)

Total download size: 4.1 M
Is this ok [y/N]: n

A yum upgrade now will be happy, too.

AFAIU, the problem is, that the Percona repo conflicts with mysql-libs from base.
You are conflicting with the CentOS Base repository here!
Not sure if this conflict could cause trouble during future installs or upgrades.

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXC-1263

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers