Percona XtraDB Cluster - HA scalable solution for MySQL

An explicitly set wsrep_node_incoming_address may make SHOW STATUS LIKE 'wsrep_incoming_addresses' return a portless address

Reported by Brian Fraser on 2012-11-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
MySQL patches by Codership
Medium
Alex Yurchenko
Percona Toolkit
Medium
Brian Fraser
Percona XtraDB Cluster
Undecided
Unassigned

Bug Description

Title's a mouthful. This is basically an enhancement request to this: https://bugs.launchpad.net/galera/+bug/1003908

> SHOW STATUS LIKE 'wsrep_incoming_addresses';

gives precedence to wsrep_node_incoming_address, which is good, but since the recommended practice is setting wsrep_node_incoming_address to an IP without a port section, it makes the status return something like '10.11.12.77,10.11.12.77,10.11.12.77', which is useless.

So, if the address doesn't have a port bit, would it be possible to return the address + mysqld_port? This will make node autodiscovery in Percona Toolkit a breeze.

Tags: pxc Edit Tag help
Brian Fraser (fraserbn) wrote :

Also, changing the docs to use addr:port would be fantastic.

Changed in percona-toolkit:
status: New → Confirmed
importance: Undecided → Medium
Alex Yurchenko (ayurchen) wrote :

> recommended practice is setting wsrep_node_incoming_address to an IP without a port section

Since when is it recommended?

Brian Fraser (fraserbn) wrote :

Every single example I could google has it with just the address. I admit that's not the same as "recommended" -- but how many people are going to dig up the docs and find out that you an put addr:port?

no longer affects: galera
Changed in codership-mysql:
assignee: nobody → Alex Yurchenko (ayurchen)
importance: Undecided → Medium
milestone: none → 5.5.28-23.8
status: New → Confirmed
Alex Yurchenko (ayurchen) wrote :

Pushed in lp:codership-mysql/5.5 r3841 - fixes to use mysqld_port when no port (no ':') is found in wsrep_node_incoming_address. wsrep_node_incoming_address however remains unchanged - not sure what would be the right thing to do in that case.

Changed in codership-mysql:
status: Confirmed → Fix Committed
Seppo Jaakola (seppo-jaakola) wrote :
Changed in codership-mysql:
milestone: 5.5.29-24.8 → 5.5.29-23.7.1
Alex Yurchenko (ayurchen) wrote :

fix released in 23.7.3

Changed in codership-mysql:
status: Fix Committed → Fix Released
Changed in percona-xtradb-cluster:
milestone: none → 5.5.30-23.7.4
status: New → Fix Released
Changed in percona-toolkit:
milestone: none → 2.2.2
tags: added: pxc
Brian Fraser (fraserbn) on 2013-04-02
Changed in percona-toolkit:
assignee: nobody → Brian Fraser (fraserbn)
Changed in percona-toolkit:
status: Confirmed → In Progress
Brian Fraser (fraserbn) on 2013-04-16
Changed in percona-toolkit:
status: In Progress → Fix Committed
Changed in percona-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers