Percona XtraDB Cluster - HA scalable solution for MySQL

debian packages include outdated innotop

Reported by John Fitzpatrick on 2012-08-02
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server
Status tracked in 5.6
5.1
Low
Alexey Bychko
5.5
Medium
Alexey Bychko
5.6
Medium
Laurynas Biveinis
Percona XtraDB Cluster
Undecided
Unassigned

Bug Description

Remove innotop from debian packages.

It isn't in RPMs and we should be consistent with upstream.

Also, innotop should be in its own package if we are going to package it.

Tags: pkg Edit Tag help

Percona server client 5.5 package doesn't provide innotop. It is available as a separate package innotop.

rpm -ql Percona-Server-client-55-5.5.24-rel26.0.256.rhel6.x86_64
/usr/bin/hsclient
/usr/bin/msql2mysql
/usr/bin/mysql
/usr/bin/mysql_find_rows
/usr/bin/mysql_waitpid
/usr/bin/mysqlaccess
/usr/bin/mysqlaccess.conf
/usr/bin/mysqladmin
/usr/bin/mysqlbinlog
/usr/bin/mysqlcheck
/usr/bin/mysqldump
/usr/bin/mysqlimport
/usr/bin/mysqlshow
/usr/bin/mysqlslap
/usr/share/man/man1/msql2mysql.1.gz
/usr/share/man/man1/mysql.1.gz
/usr/share/man/man1/mysql_find_rows.1.gz
/usr/share/man/man1/mysql_waitpid.1.gz
/usr/share/man/man1/mysqlaccess.1.gz
/usr/share/man/man1/mysqladmin.1.gz
/usr/share/man/man1/mysqlbinlog.1.gz
/usr/share/man/man1/mysqlcheck.1.gz
/usr/share/man/man1/mysqldump.1.gz
/usr/share/man/man1/mysqlimport.1.gz
/usr/share/man/man1/mysqlshow.1.gz
/usr/share/man/man1/mysqlslap.1.gz

or is this a feature request to have innotop included in Percona Server client package?

Apologies, I should have been more specific - I was referring to a Debian/Ubuntu package, which does bundle innotop:

~$ dpkg-query --show percona-server-client-5.5
percona-server-client-5.5 5.5.25a-rel27.1-277.precise

~$ dpkg -L percona-server-client-5.5
...
/usr/bin/innotop
...

Volans (volans) wrote :

I can confirm it, in the Debian percona-server-client-5.5 package (5.5.25a-rel27.1-277.squeeze) the shipped version of innotop is very old and from an obsolete source:

version: 1.6.0 (revision 383)
source: https://innotop.svn.sourceforge.net/svnroot/innotop/trunk/innotop

Innotop development has moved from Sourceforge time ago, I think that the current development is done on Google Code:

http://code.google.com/p/innotop/

Bug confirmed. I've installed percona-server-client-5.5 and I get an old innotop 1.6.0.

root@debian:~# apt-get install percona-server-client
[...]
  percona-server-client percona-server-client-5.5 percona-server-common-5.5
[...]

root@debian:~# dpkg -L percona-server-client-5.5 | egrep innotop$
/usr/bin/innotop

root@debian:~# innotop --version
innotop Ver 1.6.0 Changeset 383 from trunk/innotop

Thank you for your report.

Changed in percona-server:
status: New → Confirmed
Changed in percona-server:
assignee: nobody → Ignacio Nin (ignacio-nin)
importance: Undecided → Medium
Stewart Smith (stewart) wrote :

It's rather strange that we ship it in debian package but not RPM, and it should probably be its own package anyway.

summary: - innotop version outdated in percona-server-client-5.5 package
+ debian packages include outdated innotop
description: updated
Stewart Smith (stewart) on 2012-12-11
Changed in percona-server:
status: Confirmed → Triaged
Alexey Bychko (abychko) on 2013-02-04
Changed in percona-server:
assignee: Ignacio Nin (ignacio-nin) → Alexey Bychko (abychko)
tags: added: pkg
Changed in percona-xtradb-cluster:
milestone: none → 5.5.30-23.7.4
Ignacio Nin (ignacio-nin) wrote :

5.6 will be automatically fix when the 5.5 branch is merged onto 5.6

Changed in percona-xtradb-cluster:
status: New → Fix Released
Scott Briggs (scott-br) wrote :

It's rather strange that you guys would remove it instead of updating it and adding it to the rpm or at least adding it to the Percona toolkit. It probably wasn't in the RPM because it's already in RPM form on google code but there is no deb package.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers