Percona XtraDB Cluster - HA scalable solution for MySQL

set gcs.fc_master_slave=YES gives error

Reported by Jay Janssen on 2012-06-12
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
MySQL patches by Codership
Medium
Seppo Jaakola
Percona XtraDB Cluster
Status tracked in Trunk
5.6
Undecided
Unassigned
Trunk
Undecided
Unassigned

Bug Description

mysql> set global wsrep_provider_options="gcs.fc_master_slave=YES";
ERROR 1210 (HY000): Incorrect arguments to SET
mysql> show variables like 'wsrep_provider_options';
+------------------------+-------------------------+
| Variable_name | Value |
+------------------------+-------------------------+
| wsrep_provider_options | gcs.fc_master_slave=YES |
+------------------------+-------------------------+
1 row in set (0.00 sec)

Two issues here:
- The 'incorrect arguments' error
- When I set an invalid parameter in wsrep_provider_options, SHOW VARIABLES incorrectly shows me the bad setting, and not all the settings within wsrep_provider_options

Jay Janssen (jay-janssen) wrote :

I believe this is simply a non-dynamic variable. However, the behavior of SHOW VARIABLES should be addressed.

Confirmed.

gcs.c seems to be missing something similar to:

    else if (!strcmp (key, GCS_PARAMS_SYNC_DONOR)) {
        return _set_sync_donor (conn, value);
    }

well, it may be that this is indeed a non-dynamic variable (though I see conn->params.fc_master_slave ), but having a dummy method in that case may help.

Changed in percona-xtradb-cluster:
status: New → Confirmed
Alex Yurchenko (ayurchen) wrote :

lp:1066864 and lp:1069271 are duplicates

Changed in codership-mysql:
importance: Undecided → Medium
milestone: none → 5.5.30-24.8
status: New → Confirmed
Changed in percona-xtradb-cluster:
milestone: none → 5.5.30-24.8
Seppo Jaakola (seppo-jaakola) wrote :

The fix reads back the effective provider options from wsrep provider plugin, after a failed attempt to change options.
set gcs.fc_master_slave is not dynamic option, hence the failure in the SET command in the first place.

The fix is pushed in revision: http://bazaar.launchpad.net/~codership/codership-mysql/5.5-23/revision/3869

Changed in codership-mysql:
status: Confirmed → In Progress
assignee: nobody → Seppo Jaakola (seppo-jaakola)
milestone: 5.5.30-24.8 → 5.5.31-23.7.4
status: In Progress → Fix Committed
Changed in percona-xtradb-cluster:
status: Confirmed → Fix Released
Changed in codership-mysql:
status: Fix Committed → Fix Released

This issue is there in 5.6 too, hence the fix https://bazaar.launchpad.net/~codership/codership-mysql/5.5-23/revision/3869#sql/wsrep_var.cc needs to be ported to 5.6 tree.

Seppo Jaakola (seppo-jaakola) wrote :

Right, will merge this to wsrep-5.6 branch as well

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers