innobackupex applylog fails due to incorrectly reporting extra undo slots

Reported by Josh Boon on 2012-03-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona XtraBackup
Undecided
Unassigned

Bug Description

All versions of xtrabackup including 1.6.4, 1.6.5, and 1.9.1 all fail when apply logs with the error:

InnoDB: Error: innodb_extra_undoslots option is disabled, but it was enabled before.
InnoDB: The datafile is not normal for mysqld and disabled innodb_extra_undoslots.
InnoDB: Enable innodb_extra_undoslots if it was enabled before, and
InnoDB: ### don't use this datafile with other mysqld or ibbackup! ###
InnoDB: Cannot continue operation for the safety. Calling exit(1).
innobackupex: Error:
innobackupex: ibbackup failed at /usr/bin/innobackupex line 349.

I'm running MySQL 5.1.56 on a clean install Red Hat 5.8. The MySQL install was built by Rackspace so I'm trying to scare up the source code from them to make sure nothing strange is happening. Let me know what else you folks need to get this off the ground. We picked up the same error when we tried to switch over to the Percona Server binaries as well.

Alexey Kopytov (akopytov) wrote :

Josh,

Can you give the full command that was used to apply logs and its full output?

Changed in percona-xtrabackup:
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for Percona XtraBackup because there has been no activity for 60 days.]

Changed in percona-xtrabackup:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers