tar4ibd does not use O_DIRECT for per-table *.ibd when it should

Reported by Alexey Kopytov on 2012-02-02
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Percona XtraBackup
High
Alexey Kopytov
1.6
High
Alexey Kopytov
2.0
Undecided
Unassigned

Bug Description

innobackupex invokes tar4ibd with the -d switch to make it use O_DIRECT when it's used by the server (i.e. when innodb_flush_method=O_DIRECT).

The problem is that -d is only passed when streaming ibdata* files, but not when streaming *.ibd. So the fix for bug #606981 was incomplete. It should be extended to cover *.ibd file streaming as well.

Alexey Kopytov (akopytov) wrote :

Won't fix in 2.0 as the problem will not exist there once the parallel compression branch is merged (and thus, tar4ibd goes away).

Changed in percona-xtrabackup:
importance: Undecided → High
status: New → Fix Committed
assignee: nobody → Alexey Kopytov (akopytov)
Changed in percona-xtrabackup:
status: Fix Committed → Fix Released
tags: added: cr i21103
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions