ibbackup-binary option in innobackupex does not work

Reported by Dan Rogart on 2011-07-11
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Percona XtraBackup
Undecided
Alexey Kopytov
1.6
Undecided
Alexey Kopytov
2.0
Undecided
Alexey Kopytov

Bug Description

innobackupex has the following parameter defined (see innobackupex --help or perldoc innobackupex):

--ibbackup-binary=IBBACKUP-BINARY
        This option specifies which xtrabackup binary should be used. The
        option accepts a string argument. IBBACKUP-BINARY should be the
        command used to run XtraBackup. The option can be useful if the
        xtrabackup binary is not in your search path or working directory.

However, it does not seem to work when invoked:

[drogart@some_server bin]$ ./innobackupex --ibbackup-binary=xtrabackup_51
Unknown option: ibbackup-binary
innobackupex: Bad command line arguments

I am using the 1.6 xtrabackup scripts and binaries, installed via tar.gz on a CentOS 5.2 system. FWIW, the autodetection seems to work OK, except that if your xtrabackup binaries are not in the $PATH then it will fail with a different error (already reported here by someone else: https://bugs.launchpad.net/percona-xtrabackup/+bug/806531).

I can work around this, but it's not optimal that one of the defined script parameters doesn't work at all. Maybe I'm missing something simple?

Thanks,
Dan Rogart

Alexey Kopytov (akopytov) wrote :

This is different from bug #729497. The actual option name recognized by innobackupex is --ibbackup, rather than --ibbackup-binary mentioned in the doc.

The fix is 's/ibbackup-binary/ibbackup' in innobackupex.

Changed in percona-xtrabackup:
status: New → Confirmed
Dan Rogart (drogart) wrote :

Thanks, that's easy to fix. Although doing that seems to force the script to just autodetect what version of the binary to use. Are there plans to make innobackupex correctly use --ibbackup moving forward? The autodection is OK, but it has some issues if the binaries are not in your PATH.

Thanks much,
Dan

On Tue, 12 Jul 2011 19:02:30 -0000, Dan Rogart <email address hidden> wrote:
> Thanks, that's easy to fix. Although doing that seems to force the
> script to just autodetect what version of the binary to use. Are there
> plans to make innobackupex correctly use --ibbackup moving forward? The
> autodection is OK, but it has some issues if the binaries are not in
> your PATH.

Yes, that's the fixed bug that I originally set to duplicate of this one
(without realising the help was also wrong).

i.e. it's fixed in next release.

--
Stewart Smith

Adrian Chapela (adrian-chapela) wrote :

Also documentation page from Percona is incorrect.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers