xtrabackup debs should depend on mysql command line client (innobackupex needs it)

Reported by Valentine Gostev on 2011-05-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona XtraBackup
Medium
Ignacio Nin
1.6
Medium
Ignacio Nin
2.0
Medium
Ignacio Nin

Bug Description

[root@gval-cent5-64-n402 distr]# rpm -ihv xtrabackup-1.6-245.rhel5.x86_64.rpm
error: Failed dependencies:
        mysql is needed by xtrabackup-1.6-245.rhel5.x86_64

But on ubuntu xtrabackup does not depend on mysql. We should either remove dependency from RPM packages, or add them to .deb packages.

I think better one is to remove dependency from RPM - we do not need any part of mysql o prepare backup for restore.

Changed in percona-xtrabackup:
status: New → Confirmed
importance: Undecided → Wishlist
importance: Wishlist → Low
assignee: nobody → Stewart Smith (stewart)
milestone: none → 1.7
summary: - xrabackup should not depend on mysql binary (RPM)
+ xtrabackup should not depend on mysql binary (RPM)

mysql command line client is needed by innobackupex script - so we should have it as a dependency.

Changed in percona-xtrabackup:
assignee: Stewart Smith (stewart) → Ignacio Nin (ignacio-nin)
summary: - xtrabackup should not depend on mysql binary (RPM)
+ xtrabackup debs should depend on mysql command line client (innobackupex
+ needs it)
Stewart Smith (stewart) on 2011-05-20
Changed in percona-xtrabackup:
status: Confirmed → Triaged
importance: Low → Medium
Ignacio Nin (ignacio-nin) wrote :

Since innobackupex uses mysql(1) for the communication with the server, the deb package was fixed to depend on mysql-client.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers