Extend the list of MySQL versions for test in XtraBackup's testing suite

Bug #697372 reported by Valentine Gostev on 2011-01-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona XtraBackup moved to https://jira.percona.com/projects/PXB
Fix Released
Medium
Stewart Smith
1.6
Fix Released
Medium
Stewart Smith
2.0
Fix Released
Medium
Stewart Smith
2.1
Fix Released
Medium
Stewart Smith

Bug Description

The XtraBackup's testing suite should allow to run tests against the following versions of MySQL

Using xtrabackup_51 binary:
- MySQL 5.0
- Percona Server 5.0
- MySQL with built-in InnoDB plug-in

Using xtrabackup binary:
- MySQL 5.1 w/ InnoDB plug-in
- Percona Server 5.1

xtrabackup_55
- Percona Server 5.5
- MySQL 5.5

Related branches

Changed in percona-xtrabackup:
assignee: nobody → Valentine Gostev (core-longbow)
Changed in percona-xtrabackup:
status: New → Confirmed
Changed in percona-xtrabackup:
importance: Undecided → Medium
Changed in percona-xtrabackup:
milestone: none → 1.6
description: updated
Valentine Gostev (longbow) wrote :

Current status: links to Percona Server 5.0 and 5.5 should be specified.

Changed in percona-xtrabackup:
status: Confirmed → Fix Committed
Changed in percona-xtrabackup:
milestone: 1.6 → 1.7
Stewart Smith (stewart) wrote :

I think we have this now with the testsuite fixes that Alexey and I have done? or are there other changes pending?

Alexey Kopytov (akopytov) wrote :

5.0 is still unsupported with those fixes. OTOH I wonder if 5.0 is officially supported by the current xtrabackup and hence need testing in trunk.

Stewart Smith (stewart) wrote :

http://www.percona.com/docs/wiki/percona-xtrabackup:xtrabackup:start says 5.0 is supported, so we should be testing against it.

Stewart Smith (stewart) wrote :

I don't see any fix actually committed, so it looks like this is still TODO

Changed in percona-xtrabackup:
status: Fix Committed → Confirmed
Alexey Kopytov (akopytov) wrote :

bootstrap.sh and possibly run.sh have to be updated to allow testing MySQL / Percona Server 5.0. All other parts have been implemented by the recent test suite fixes.

Stewart Smith (stewart) on 2012-01-11
Changed in percona-xtrabackup:
milestone: 1.9.0 → 1.9.1
Stewart Smith (stewart) on 2012-02-20
Changed in percona-xtrabackup:
milestone: 1.9.1 → 1.9.2
Stewart Smith (stewart) on 2012-03-05
Changed in percona-xtrabackup:
milestone: 1.9.2 → none
Stewart Smith (stewart) wrote :

Setting to fix released as we do now cover MySQL 5.0.

We're still not doing anything about multiple minor releases in each major one though.

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXB-554

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers