innobackupex cannot treat exit code of xtrabackup executable

Reported by Yasufumi Kinoshita on 2010-03-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona XtraBackup
High
Daniel Nichter

Bug Description

Even if xtrabackup exit with error code, innobackupex script output "completed OK!".

(example)
xtrabackup: Stopping log copying thread..
xtrabackup: Error: log_copying_thread failed.
...
100301 15:43:52 innobackupex-1.5.1: completed OK!

That is because xtrabackup is executed from fork child process and the parent process don't know the exit code of the child process.

Changed in percona-xtrabackup:
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Daniel Nichter (daniel-percona)
Changed in percona-xtrabackup:
status: Confirmed → Fix Committed
Changed in percona-xtrabackup:
milestone: none → 1.6
Changed in percona-xtrabackup:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers