xtrabackup does not handle innodb=force in my.cnf

Bug #528752 reported by Andrew Garner on 2010-02-26
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Percona XtraBackup moved to https://jira.percona.com/projects/PXB
Fix Released
Medium
Laurynas Biveinis
1.6
Won't Fix
Medium
Laurynas Biveinis
2.0
Fix Released
Medium
Laurynas Biveinis
2.1
Fix Released
Medium
Laurynas Biveinis

Bug Description

With a my.cnf such as the following (mysql 5.1.42 on a rhel5 64-bit system):

/etc/my.cnf:
[mysqld]
...
innodb=force
...

Xtrabackup fails with the following error:

# xtrabackup --backup --target-dir=/root/foo/
xtrabackup: ambiguous option '--innodb=force' (innodb_adaptive_hash_index, innodb_open_files)

innodb=force is, of course, new in 5.1.36+ (or thereabouts). xtrabackup was compiled against stock 5.1.42 from dev.mysql.com using the patch against the innodb_plugin.

Workaround: use loose-innodb=force, but it would be nice to have this fixed. :)

Related branches

Changed in percona-xtrabackup:
milestone: none → release-1.2
assignee: nobody → Aleksandr Kuzminsky (akuzminsky)
Changed in percona-xtrabackup:
milestone: 1.2 → 1.3.1
Peter Zaitsev (pz-percona) wrote :

Guys,

This is set to milestone 1.3.1 with 1.5 already out.
The bug still exists and it is very annoying as using innodb=force is a good method to avoid getting MySQL started with Innodb engine available as it can happen in some cases.

Changed in percona-xtrabackup:
milestone: 1.3.1 → 1.6
assignee: Aleksandr Kuzminsky (akuzminsky) → Valentine Gostev (core-longbow)
tags: added: cr
tags: added: xtrabackup
Changed in percona-xtrabackup:
status: New → Confirmed
importance: Undecided → Medium
milestone: 1.6 → none
assignee: Valentine Gostev (core-longbow) → Vadim Tkachenko (vadim-tk)
Changed in percona-xtrabackup:
assignee: Vadim Tkachenko (vadim-tk) → Alexey Kopytov (akopytov)
milestone: none → 1.6
status: Confirmed → Triaged
Changed in percona-xtrabackup:
milestone: 1.6 → 1.7
Stewart Smith (stewart) on 2011-06-02
Changed in percona-xtrabackup:
milestone: 1.7.0beta1 → 1.7.0
tags: added: i23069
tags: added: i23299
Andrew Garner (muzazzi) wrote :

Linked a branch that has an initial patch to allow --innodb=<value> against xb2.1, since this still seems to be an issue.

tags: added: contribution

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXB-541

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers