xtrabackup not handling barracuda compressed table format

Reported by vibhor on 2009-12-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona XtraBackup
Undecided
Unassigned

Bug Description

Hello,

I am unable to run xtrabackup against a barracuda compressed table. Here is what happens:

xtrabackup --backup --target-dir=/backup --innodb_file_per_table
xtrabackup Ver 1.0 Rev 113 for 5.0.84 unknown-linux-gnu (x86_64)
xtrabackup: uses posix_fadvise().
xtrabackup: cd to /disk2/mysql
xtrabackup: Target instance is assumed as followings.
xtrabackup: innodb_data_home_dir = ./
xtrabackup: innodb_data_file_path = ibdata1:10M:autoextend
xtrabackup: innodb_log_group_home_dir = ./
xtrabackup: innodb_log_files_in_group = 2
xtrabackup: innodb_log_file_size = 536870912
>> log scanned up to (243 3287007327)
Copying ./ibdata1
     to /backup/ibdata1
xtrabackup: Database page corruption detected at page 64. retrying...
xtrabackup: Database page corruption detected at page 64. retrying...
xtrabackup: Database page corruption detected at page 64. retrying...
xtrabackup: Database page corruption detected at page 64. retrying...
xtrabackup: Database page corruption detected at page 64. retrying...
xtrabackup: Database page corruption detected at page 64. retrying...
xtrabackup: Database page corruption detected at page 64. retrying...
xtrabackup: Database page corruption detected at page 64. retrying...
xtrabackup: Database page corruption detected at page 64. retrying...
xtrabackup: Error: 10 retries resulted in fail. This file seems to be corrupted.
xtrabackup: Error: xtrabackup_copy_datafile() failed.
xtrabackup: Error: failed to copy system datafile.

This happens on both machines where I am using the barracuda compressed table format with percona's mysql release. On the two machines where I am running stock mysql with innodb I am able to complete the backup successfully.

Naturally, "for 5.0" version cannot treat Barracuda.
Building with InnoDB-Plugin is needed.

Changed in percona-xtrabackup:
assignee: nobody → Aleksandr Kuzminsky (akuzminsky)
vibhor (vibhor-chowdhary) wrote :

An update on this. I built the xtrabackup binary using the source code using mysql-5.1.34.tar.gz (source) and the xtrabackup-1.0.tar.gz (source). I used the build script: xtrabackup-1.0/innobase/xtrabackup/utils/build51tree.sh

The build failed while compiling xtrabackup, so I had to edit the xtrabackup-build/mysql-5.1.34/storage/innobase/xtrabackup/Makefile to comment out the MySQL 5.0 build instructions and uncomment the MySQL 5.1 build instructions. Then ran make to finish the building. Using this binary against a database with barracuda compressed tables I ran into the exact same errors as with the RHEL 5 binary RPM released by Percona built against MySQL 5.0. Here is the output:

./xtrabackup --backup --target-dir=/backup --innodb_file_per_table
xtrabackup: tables regcomp(): Success
./xtrabackup Ver undefined Rev undefined for 5.1.34 unknown-linux-gnu (x86_64)
xtrabackup: uses posix_fadvise().
xtrabackup: cd to /disk2/mysql
xtrabackup: Target instance is assumed as followings.
xtrabackup: innodb_data_home_dir = ./
xtrabackup: innodb_data_file_path = ibdata1:10M:autoextend
xtrabackup: innodb_log_group_home_dir = ./
xtrabackup: innodb_log_files_in_group = 2
xtrabackup: innodb_log_file_size = 536870912
xtrabackup: use O_DIRECT
>> log scanned up to (88 3867384681)
Copying ./ibdata1
     to /backup/ibdata1
xtrabackup: Database page corruption detected at page 64. retrying...
xtrabackup: Database page corruption detected at page 64. retrying...
xtrabackup: Database page corruption detected at page 64. retrying...
xtrabackup: Database page corruption detected at page 64. retrying...
xtrabackup: Database page corruption detected at page 64. retrying...
xtrabackup: Database page corruption detected at page 64. retrying...
xtrabackup: Database page corruption detected at page 64. retrying...
xtrabackup: Database page corruption detected at page 64. retrying...
xtrabackup: Database page corruption detected at page 64. retrying...
xtrabackup: Error: 10 retries resulted in fail. This file seems to be corrupted.
xtrabackup: Error: xtrabackup_copy_datafile() failed.
xtrabackup: Error: failed to copy system datafile.

Let me know if you need any more information. Perhaps my build method was flawed.

Regards

vibhor (vibhor-chowdhary) wrote :

Forgot to add that I was unable to build the xtrabackup binary against the mysql-xtradb 5.1.34 source since patching fails. I will attempt to build against 5.1.34 with the InnoDB plugin.

I think that is the issue, since I didn't build it against the innodb-plugin (only vanilla mysql). So please disregard previous post.

Changed in percona-xtrabackup:
status: New → Fix Committed
status: Fix Committed → Confirmed
assignee: Aleksandr Kuzminsky (akuzminsky) → Yasufumi Kinoshita (yasufumi-kinoshita)
Changed in percona-xtrabackup:
status: Confirmed → Fix Committed
Percona (percona-team) on 2010-11-25
Changed in percona-xtrabackup:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers