innobackupex-1.5.1 gets wrong temp dir

Bug #434486 reported by Christian Kaps on 2009-09-22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona XtraBackup moved to
Fix Released
Aleksandr Kuzminsky

Bug Description

In the latest 1.0 release there is an error in the innobackupex-1.5.1 script.

./innobackupex-1.5.1 --port 3306 --user=xtrabackup --password='*********' --stream=tar --defaults-file=/etc/my.cnf /var/lib/mysql | gzip - > /srv/mysql/backups/test.tar.gz

InnoDB Backup Utility v1.5.1-xtrabackup; Copyright 2003, 2009 Innobase Oy.
All Rights Reserved.

This software is published under
the GNU GENERAL PUBLIC LICENSE Version 2, June 1991.

IMPORTANT: Please check that the backup run completes successfully.
           At the end of a successful backup run innobackup
           prints "innobackup completed OK!".

innobackupex: Using mysql Ver 14.14 Distrib 5.1.39, for unknown-linux-gnu (x86_64) using readline 5.1
innobackupex: Using mysql server version 5.1.39-community-log

innobackupex: Created backup directory /var/lib/mysql
sh: line 0: cd: /tm: No such file or directory
tar: backup-my.cnf: Cannot stat: No such file or directory
tar: Error exit delayed from previous errors
innobackupex: Error: Failed to stream 'backup-my.cnf': Inappropriate ioctl for device at ./innobackupex-1.5.1 line 452.

When I change the line 1558:

my $filename_dir = substr($filename, 0, rindex($filename, '/') - 1);


my $filename_dir = substr($filename, 0, rindex($filename, '/'));

it works for me.


Changed in percona-xtrabackup:
assignee: nobody → Aleksandr Kuzminsky (akuzminsky)
importance: Undecided → Low
Changed in percona-xtrabackup:
status: New → Confirmed
Changed in percona-xtrabackup:
status: Confirmed → In Progress
Changed in percona-xtrabackup:
status: In Progress → Fix Released

I managed to cause this error a different way: I was piping the output into gzip, but changed it to pigz (parallel gzip, makes a huge difference to backup speed), however, I'd failed to actually install pigz! innobackupex was thus piping the output into a non-existent program and it caused the same error as this. I don't know if it's reasonable to expect innobackupex to deal with that situation, but it did produce exactly the same error.

Percona now uses JIRA for bug reports so this bug report is migrated to:

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers