Comment 2 for bug 395407

Revision history for this message
Yasufumi Kinoshita (yasufumi-kinoshita) wrote :

This bug is caused by,,,,

------------------------------------------------------------
revno: 66
committer: Vadim Tkachenko <email address hidden>
branch nick: trunk
timestamp: Wed 2009-06-17 23:05:21 -0700
message:
  Added incremental option to innobackupex-1.5.1 script
------------------------------------------------------------

@@ -1555,9 +1567,10 @@
             print STDERR "$prefix Warning: perl $required_version or newer!\n";
         }
     } else {
- $perl_version = chr($required_perl_version[0])
- . chr($required_perl_version[1])
- . chr($required_perl_version[2]);
+ #$perl_version = chr($required_perl_version[0])
+ #. chr($required_perl_version[1])
+ #. chr($required_perl_version[2]);
+ $perl_version = "v$required_perl_version[0].$required_perl_version[1].$required_perl_version[2]";
         if ($^V lt $perl_version) {
             my $version = chr(48 + $required_perl_version[0])
                 . "." . chr(48 + $required_perl_version[1])

I don't know why the change was done....
I will revert....