innobackupex reports "perl is too old"

Bug #395407 reported by Andrew Garner
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Percona XtraBackup moved to https://jira.percona.com/projects/PXB
Fix Released
Medium
Unassigned

Bug Description

Running xtrabackup-0.8 from xtrabackup-0.8-1.rhel5.x86_64.rpm on RHEL 5 I get the following spurious warning when running innobackupex:

# innobackupex-1.5.1 --stream=tar /tmp > /dev/null
innobackupex: Warning: Your perl is too old! Innobackup requires
innobackupex: Warning: perl 5.0.5 or newer!

# perl --version

This is perl, v5.8.8 built for x86_64-linux-thread-multi

Changed in percona-xtrabackup:
assignee: nobody → Yasufumi Kinoshita (yasufumi-kinoshita)
importance: Undecided → Medium
Revision history for this message
Keith Murphy (bmurphy) wrote :

I built xtrabackup-0.8 from source on a Centos 5.3 system and got the same warning message:

bash-3.2$ /usr/bin/innobackupex-1.5.1 --user=root --password=rach123el /backups/full_backups
innobackupex: Warning: Your perl is too old! Innobackup requires
innobackupex: Warning: perl 5.0.5 or newer!

As before I am running perl 5.8.8 (from rpm package):

-bash-3.2$ perl --version

This is perl, v5.8.8 built for x86_64-linux-thread-multi

Hope this helps.

Revision history for this message
Yasufumi Kinoshita (yasufumi-kinoshita) wrote :

This bug is caused by,,,,

------------------------------------------------------------
revno: 66
committer: Vadim Tkachenko <email address hidden>
branch nick: trunk
timestamp: Wed 2009-06-17 23:05:21 -0700
message:
  Added incremental option to innobackupex-1.5.1 script
------------------------------------------------------------

@@ -1555,9 +1567,10 @@
             print STDERR "$prefix Warning: perl $required_version or newer!\n";
         }
     } else {
- $perl_version = chr($required_perl_version[0])
- . chr($required_perl_version[1])
- . chr($required_perl_version[2]);
+ #$perl_version = chr($required_perl_version[0])
+ #. chr($required_perl_version[1])
+ #. chr($required_perl_version[2]);
+ $perl_version = "v$required_perl_version[0].$required_perl_version[1].$required_perl_version[2]";
         if ($^V lt $perl_version) {
             my $version = chr(48 + $required_perl_version[0])
                 . "." . chr(48 + $required_perl_version[1])

I don't know why the change was done....
I will revert....

Changed in percona-xtrabackup:
status: New → Fix Committed
Changed in percona-xtrabackup:
status: Fix Committed → Fix Released
Revision history for this message
Shahriyar Rzayev (rzayev-sehriyar) wrote :

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXB-533

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers