ibbackup_binlog_marker bug still persists

Reported by Brad Fino on 2009-06-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona XtraBackup
Medium
Unassigned

Bug Description

Can an ibbackup_binlog_marker failure be handled more gracefully? this bug was *supposed* to have been fixed in earlier versions of ibbackup, but it still persists to this day. In any event ... even in Xtrabackup it'll still create the table and then under some random condition it'll drop the table but it'll still exist in the data dictionary so you can't delete/create it without going through a 4 or 5 step procedure.

innobackupex: Error: mysql child process has died: ERROR 1005 (HY000) at line 7: Can't create table './mysql/ibbackup_binlog_marker.frm' (errno: -1)
 while waiting for reply to MySQL request: 'CREATE TABLE ibbackup_binlog_marker(a INT) ENGINE=INNODB;' at /usr/bin/innobackupex-1.5.1 line 433.

Does this table even need to be innodb? That seems to be the crux of the problem right there. Can this table failure be handled more gracefully? Like ... if it can't create it, create ibbackup_binlog_marker1? Or make it MyISAM so it doesn't think it's still in the data dictionary but doesn't actually exist?

Changed in percona-xtrabackup:
assignee: nobody → Yasufumi Kinoshita (yasufumi-kinoshita)
importance: Undecided → Medium
status: New → Confirmed

Thank you for reporting.
let me reorder the facts...

innobackupex-1.5.1 is based on innobackup-1.5.1.
And currently, ibbackup_binlog_marker handling is as it is at innobackup-1.5.1.
So, "this bug"? is also for innobackup.
I think that for "ibbackup", the table must be name "ibbackup_binlog_marker" and be innodb table.

But, even ibbackup may use the ibbackup_binlog_marker table, but xtrabackup doesn't use it at all.
So, the table is not needed for xtrabackup at all, though ibbackup may need the table to be innodb.

Then,
Should we remove the "ibbackup_binlog_marker" feature entirely from innobackupex-1.5.1?

How do you think about?

Brad Fino (mrfino) wrote :

If Xtrabackup doesn't use it, then by all means remove :) Looking at the code it looks like it's just a check to see if MySQL is still alive when it inserts a '1' into the table ?

ibbackup_binlog_marker feature is removed at the revision.

http://bazaar.launchpad.net/~percona-dev/percona-xtrabackup/trunk/revision/89

Changed in percona-xtrabackup:
status: Confirmed → Fix Committed
Changed in percona-xtrabackup:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers