Running Xtrabackup 2.4.5 with ssl=0 in [mysqld] section of the configuration file emits a warning

Bug #1652942 reported by pako on 2016-12-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona XtraBackup moved to https://jira.percona.com/projects/PXB
New
Undecided
Unassigned

Bug Description

The xtrabackup.cnf file we use for Xtrabackup is automatically created by our management system based on /etc/mysql/my.cnf and it looks like this:

[client]
port = 3306
socket = /run/mysqld/mysqld.sock
...

[mysqld]
ssl = 0
...

[xtrabackup]
user = backup
password = XXX
...

It causes the following errors:

WARNING: --ssl is deprecated and will be removed in a future version. Use --ssl-mode instead.
Unrecognized character \x01; marked by <-- HERE after <-- HERE near column 1 at - line 1374.

even though "ssl = 0" is not deprecated for [mysqld] section and Xtrabackup shouldn't complain about it. The warning causes backups to fail with the following error message:

xb_stream_read_chunk(): wrong chunk magic at offset 0x2d6ded4a9.

it looks like duplicate of bug 1647340

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers