XB crashes with insufficient param.

Bug #1566228 reported by Krunal Bauskar on 2016-04-05
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Percona XtraBackup moved to https://jira.percona.com/projects/PXB
Status tracked in 2.4
2.3
Fix Released
High
Sergei Glushchenko
2.4
Fix Released
High
Sergei Glushchenko

Bug Description

1. This came up while experimenting this with PXC

2. XB has 3 step process. backup -> prepare -> move-back

3. Error occurs with move-back

4. PXC accidentally invoke XB with following params

innobackupex --defaults-file= --defaults-group=mysqld.2 --no-version-check --move-back --force-non-empty-directories ${DATA} &>${DATA}/innobackup.move.log

Note: defaults-file is empty and there is no datadir causing XB to assume that source = destination

and this eventually caused the error/crash as follows:
innobackupex version 2.4.0-rc1 based on MySQL server 5.7.10 Linux (x86_64) (revision id: 0d11984)
Error: Move file ib_logfile0 to ./ib_logfile0 failed: Destination file exists
*** Error in `innobackupex': free(): invalid pointer: 0x00007ffcf7c6042c ***
03:46:27 UTC - xtrabackup got signal 6 ;
This could be because you hit a bug or data is corrupted.
This error can also be caused by malfunctioning hardware.
Attempting to collect some information that could help diagnose the problem.
As this is a crash and something is definitely wrong, the information
collection process might fail.

Should be reproducible with standalone XB too.

Observed with XB-2.4.1 (may exist with other versions too)

I will do two things:

1. fix memory error when no files were copied at all
2. PXB will exit with error message "datadir must be specified" if datadir was not specified (via defaults-file or as command line argument) for copy-back or move-back.

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXB-471

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers