Innobackupex fails when using --throttle

Bug #1554235 reported by Agustín on 2016-03-07
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Percona XtraBackup moved to https://jira.percona.com/projects/PXB
Status tracked in 2.4
2.2
Won't Fix
Undecided
Unassigned
2.3
Fix Released
High
Sergei Glushchenko
2.4
Fix Released
High
Sergei Glushchenko

Bug Description

Innobackupex 2.4.1 is failing when using --throttle:

# strace -f -s1024 -o/tmp/innobackupex.strace /usr/bin/innobackupex --throttle=25 --no-timestamp /tmp/backup/backup_1

[...output trimmed...]

160307 21:54:58 Backup created in directory '/tmp/backup/backup_1'
MySQL binlog position: filename 'VM-ubuntu14-bin.000001', position '154'
160307 21:54:58 [00] Writing backup-my.cnf
160307 21:54:58 [00] ...done
160307 21:54:58 [00] Writing xtrabackup_info
160307 21:54:58 [00] ...done
xtrabackup: Transaction log of lsn (32348688) to (32348697) was copied.
21:54:59 UTC - xtrabackup got signal 11 ;
This could be because you hit a bug or data is corrupted.
This error can also be caused by malfunctioning hardware.
Attempting to collect some information that could help diagnose the problem.
As this is a crash and something is definitely wrong, the information
collection process might fail.

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0 thread_stack 0x10000
/usr/bin/innobackupex(my_print_stacktrace+0x2c)[0xbf63cc]
/usr/bin/innobackupex(handle_fatal_signal+0x262)[0xa04ad2]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x10340)[0x7fe093130340]
/lib/x86_64-linux-gnu/libpthread.so.0(pthread_mutex_lock+0x4)[0x7fe09312a414]
/usr/bin/innobackupex(_Z12os_event_setP8os_event+0x16)[0x8620c6]
/usr/bin/innobackupex[0x70b9ea]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x8182)[0x7fe093128182]
/lib/x86_64-linux-gnu/libc.so.6(clone+0x6d)[0x7fe09154547d]

Please report a bug at https://bugs.launchpad.net/percona-xtrabackup

Versions:

# innobackupex --version
innobackupex version 2.4.1 Linux (x86_64) (revision id: a2dc9d4)

# mysql -e "show variables like '%version%'";
+-------------------------+------------------------------+
| Variable_name | Value |
+-------------------------+------------------------------+
| innodb_version | 5.7.11 |
| protocol_version | 10 |
| slave_type_conversions | |
| tls_version | TLSv1,TLSv1.1 |
| version | 5.7.11-log |
| version_comment | MySQL Community Server (GPL) |
| version_compile_machine | x86_64 |
| version_compile_os | Linux |
+-------------------------+------------------------------+

# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.4 LTS
Release: 14.04
Codename: trusty

Attaching full innobackupex output, and will attach strace output, too.

Agustín.

Agustín (agustin-gallego) wrote :
Agustín (agustin-gallego) wrote :

Attaching strace output.

Agustín (agustin-gallego) wrote :

Attaching output of successful run with no --throttle argument set.

Looks like we don't have --throttle covered in our test suite.

pako (pakonet) wrote :

We have exactly the same problem trying to backup MySQL 5.7.11 slave server using Xtrabackup 2.4.1 with --throttle enabled.

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXB-465

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers